Crash on start

Game Version:

  • Build 101.101.33315.00
  • Platform Microsoft Store


Game Crashes when starting game. Have uninstalled and reinstalled. Can login to xbox.

Reproduction Steps:

  1. Start AoE 2 DE
  2. Select Standard Game.
  3. Setup game parameters for 4 with 3 AI
  4. Press start game
  5. Game crashes
  6. no message in windows log files

Windows 10. version 10.0.18363
NVidia GeForce GTX 960

###Other games
I also have AoE DE and this game continues to work without any problems.

Screenshot. Unable to capture game crashing when game start button is pressed. Attached is setup just prior to pressing start game button.

Hello, welcome here. How much memory is installed and which antivirus application do you use on your system? Also it might be worthwhile to wait for the new release coming next week. Also if possible add your dxdiag.txt log file to this thread.

Hi, I have 64 GB RAM. I’ve run diagnostics, sfc /scannow, etc. No problems identified.
Can’t upload the dxdiag.txt - new user
Can’t copy / paste dxdiag.txt - too many characters in post

Next idea?

Is Xbox Game Bar service and Xbox Companion-console installed?

And you forgot to mention your antivirus product if third party program is used.


Event Viewer > Windows Logs > System

For any entries at time of crash related to AoE2DE_s.exe

Woops. Bitdefender Total Security 2020 Build It does not register any notifications about AoE2 or Microsoft Store, etc.

yes, the Xbox Game Bar service and Xbox Companion Console are installed. I get a message asking if I want to open the Xbox Game Bar when AoE 2 DE starts. If I run the Xbox Companion Console, it logs me in and shows the Microsoft Store games that I’ve downloaded, including AoE 2 DE.

And for Brave6740, there are no messages appearing in the Event Viewer related to this.

No problem my friend. Did you follow these troubleshooting steps already?

Especially the Bitdefender part.

I read this and worked through all the sensible actions listed.

I tried to follow the steps for Bitdefender but it cannot access the directory mentioned in this support article so it is not possible to add the app mentioned there to the Bitdefender whitelist. Typical isn’t it?

You realise this is a protected folder?
Program Files\WindowsApps\Microsoft.MSPhoenix_101.101.32508.0_x64__8wekyb3d8bbweAoE2DE.exe

I can’t access the c:\program files\windows apps\ folder. If I change the security settings I end up having to reinstall windows 10, because everything ends up dying. I found this out with another Microsoft app bug. So I’m not going to do that again for this bug.

What I did do was to turn bitdefender off (including the firewall) and tried to run AoE 2 DE and it failed again.

And AoE2 DE worked up until two days ago. Then it simply started failing every time I tried to start a game. Bitdefender was installed and working when AoE 2 DE was working.

So the problem is not Bitdefender. Of course the first action is to blame the anti-virus. Boring.

This appears to be something core to AoE 2 DE, so hopefully the update will fix some of the bugs I’ve been reading about.

Any other ideas that won’t mush my windows 10 install are welcome.

If you launch Bitdefender as administrator you should be able to add the folder.

The correct folder name to paste is (and also enable to allow subfolders below it):
C:\Program Files\WindowsApps\Microsoft.MSPhoenix_101.101.33315.0_x64__8wekyb3d8bbwe\*.*

Or if excluding the executable:
C:\Program Files\WindowsApps\Microsoft.MSPhoenix_101.101.33315.0_x64__8wekyb3d8bbwe\Game\AoE2DE.exe

We all hope that the new build will fix a lot of issues. :slight_smile:

thx for the ideas. But they don’t work. Running Bitdefender as administrator is difficult as it uses many exe files. And the folder you provide does not give an indication of what the subfolders that should be included are. I can’t see inside the windowsapps folder and the last time I gave myself permission to see in this folder windows 10 ate itself. So I’m not going to do it.

I do hope that the new release fixes the problems. Hopefully it will arrive soon.

If you right click Bitdefender in start menu and choose run as administrator that should be sufficient. It depends on the application how it is implemented. *.* means all items in current folder, but if recursive is enabled it will also be applied to all subfolders. Some apps simulate this while using single *.

It is definitely not recommended to change permissions on the WindowsApps folder and also not needed. As administrator or user you can’t browse (or open) WindowsApps itself, but you can browse everything that is created below the folder (only as administrator). So if you paste the right path name in Bitdefender while running as administrator it should be browsable from there too.

Did this, and changed bitdefender .exe to run as administrator, reboot. Still bitdefender would not see that folder irrespective of what I put into the field to add an exception into the firewall.

I keep getting a message invalid folder. And the path is grayed, as if Bitdefender knows this is a system folder.

No other app or program has this problem. Bitdefender finds them all and notifies me that they want to access through the firewall. Simple really isn’t it?

What I find interesting is that it was working, then there was a windows patch and then it stopped working. If it was working then Bitdefender is not the problem.

How long until the fix?

I think you might be on the right path.

If it was working before and not now, i would start looking at any updates that may have come through. WIndows update history, drivers etc… Reverse those that installed prior to the game crashing

I am running the same nvidia driver version as you
Winver shows build 18363.535 - this is the latest release version as of now (1909 w/ december updates as detailed on

1 Like

FYI. I’m still running on Microsoft WHQL Nvidia driver version (2017-05-01) and I only had experienced one crash during beta time. Maybe remove all NVidia software and use Windows built-in driver support for older models. Something that you could test easily.

I really hope they fix all issues like this with next build(s).


Upgraded AoE 2 DE and the Graphics Pack, started AoE 2 DE and same problem. Crash on game start.

I decided to change the game parameters to see if this was a problem. I had selected the custom land map sherwood forest. I selected another map, tried to start the game and it worked.

So either the map is corrupted (but this should not be the case ask I uninstalled several times and deleted all files) or there is a bug with using that map.

Anyway, this may be helpful to others that find the game crashes with particular maps.

How did you change the game parameters? I’m having the same issue now.

Hi @soba3on, I started the game, went to single player, and selected a different map and number of AI players, etc. Then I tried to start the game and it worked.

Hi there,

I am writing from a kinda bad PC compared to lot of yours :
Time of this report: 1/14/2020, 09:59:29
Machine name: DESKTOP-5CJ2EO0
Operating System: Windows 10 Famille 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
System Manufacturer: HP
System Model: HP Laptop 17-ak0xx
BIOS: F.04 (type: UEFI)
Processor: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G (2 CPUs), ~3.0GHz
Memory: 4096MB RAM
Available OS Memory: 3982MB RAM
Page File: 4878MB used, 5246MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode

I have been able to play for two days a lot of single player and multiplayer games, really smooth from 1v1 to 4v4 (weirdly game was crashing when trying to play ranked, even though I had a score of 1000 at the graphic test ?).

Then the next morning impossible to launch any kind of games, always having a log finishing in “Exception type 3765269347 occurred at 00007fff7bd2a839”.

What basically happens is that the screen where I see the other players and myself loads, then the tiny red and yellow bits in the background starts freezing and game crashes to desktop.

I am aware I only meet the minimum required conditions to play this game and not the optimal ones, but as I was able to play about 20 games extremely smoothly in multiplayers with big fights using a lot of ram I think I should still be able to play this game no matter what (at least ranked 1v1 would be enough for me).

This is quite frustrating as 5 days ago I reinstalled windows and finally was able to play again, even did 1 ranked game. Then in the middle of a 4v4 multiplayer game the game crashed after 30 minutes of game (first time I had this bug, and the game crashed for 6/8 players) and after that impossible to play again. I tried reinstalling windows and the game twice, but nothing to do, always the same log error : “Exception type 3765269347 occurred at 00007fff7bd2a839”.

Thank you for your help