Crash to Desktop after a few minutes of playing AoE2 Definitive Edition steam version

I was very excited for this game. Pre-loaded yesterday, ran it for the first time today, crashes every time after a few minutes.

This is the log from one of the Windows event:

Faulting application name: AoE2DE_s.exe, version: 101.101.32875.0, time stamp: 0x5dce4e14
Faulting module name: AoE2DE_s.exe, version: 101.101.32875.0, time stamp: 0x5dce4e14
Exception code: 0x80000003
Fault offset: 0x0000000000a24c44
Faulting process ID: 0x3c80
Faulting application start time: 0x01d59b9a97dc11d0
Faulting application path: D:\Steam Games\steamapps\common\AoE2DE\AoE2DE_s.exe
Faulting module path: D:\Steam Games\steamapps\common\AoE2DE\AoE2DE_s.exe
Report ID: d950a63b-1424-4bc5-899a-ba5b964600b5
Faulting package full name:
Faulting package-relative application ID:

This is my info dump from my system information (I do meet the minimum specs):

OS Name Microsoft Windows 10 Pro
Version 10.0.18362 Build 18362
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name CABAL
System Manufacturer Gigabyte Technology Co., Ltd.
System Model H97M-D3H
System Type x64-based PC
System SKU To be filled by O.E.M.
Processor Intel® Core™ i3-4150 CPU @ 3.50GHz, 3500 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F4, 28/06/2014
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product H97M-D3H
BaseBoard Version x.x
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume4
Locale United Kingdom
Hardware Abstraction Layer Version = “10.0.18362.387”
Username CABAL\dipic
Time Zone E. Australia Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.87 GB
Available Physical Memory 3.59 GB
Total Virtual Memory 10.9 GB
Available Virtual Memory 4.34 GB
Page File Space 3.00 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not Modern Standby, Un-allowed DMA-capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Graphics card: Name NVIDIA GeForce GTX 750 Ti

I loaded a skirmish and it crashed after about 5 minutes. I re-verified the integrity of the game cache, tried again, and it worked for 30 minutes. I saved, restarted my PC, loaded the game, and it crashed after another 15 minutes. I started the Barbarossa campaign, and it crashed when I alt-tabbed out of the game. I used cheats to get to the fourth mission, and it crashed after about 5 minutes.

Try increasing page file size?

Thank you for the suggestion. It actually seems to have fixed the problem. Over an hour of play with no crashes.
Thank you.

1 Like

I tried increasing the page file and now I can enter a standard game atleast. I’ve never had to do this for any other game. I have 12 GB RAM.


Even if you increase the page file, the game still crashes after a few minutes for many people.

Just watch this guy:

1 Like

If you suspect a crash to desktop due to low memory, you can tell for sure that this is the case by looking at Event Viewer > Windows Logs > System and scrolling down to the time and date of the last crash, your error should look similar to the screenshot attached.

It will also tell you how much virtual memory AOE2:DE was consuming at the time of crash. In my case with UHD enabled, the game was consuming 11.5GB virtual memory. This is on a system with 16GB RAM.

Not all crashes will be due to lack of memory, so looking at event viewer is useful to rule that out at least.

1 Like

I have 12 GB RAM and no DLC installed and yet my game crashes after 5-20 minutes of gameplay. I get the same error like you show above. Not enough memory?!?


  • Requires a 64-bit processor and operating system

  • OS: Windows 10 64bit

  • Processor: 2.4 Ghz i5 or greater or AMD equivalent

  • Memory: 8 GB RAM

  • Graphics: Nvidia® GTX 650 or AMD HD 5850 or better

  • DirectX: Version 11

  • Network: Broadband Internet connection

  • Storage: 30 GB available space

I have a better rig than that and still my game crashes due to lack of memory! BULL****

This game SERIOUSLY needs optimization! I mean there are way more memory intense games out there that doesn’t crash my PC. Only this game does!

How much virtual memory was it using at the time of crash?

I share your hope that future patches bring optimisations, but for the time being you will need more virtual memory.

Goes without saying that it would be best if other programs are closed before launching the game. This is not aimed at you so much as to others that may be encountering this issue.

Latest crash log:

AoE2DE_s.exe (7364) 10116968448 byte,
steamwebhelper.exe (9912) 763977728 byte
MsMpEng.exe (4588) 281960448 byte.

I did it, but it didn’t work, the problem persists.

I add up to the huge list of players unable to PLAY this game.
I payed 20€ and wasted countless hours because of your unprofessionalism.

Tried without UHD, same problem.
Tried increasing pagefile, no more crash, but freezes at the same frequency (sound but image stuck).
All drivers updated, w10 up to date, no firewall/antivirus etc.

This is unacceptable, why no dev is answering at all?

Crashed twice for me today:
Faulting application name: AoE2DE_s.exe, version: 101.101.37906.0, time stamp: 0x5ed527fe
Faulting module name: CONCRT140.dll, version: 14.22.27821.0, time stamp: 0x5d0c182c
Exception code: 0xc0000005
Fault offset: 0x000000000000d828
Faulting process id: 0x2344
Faulting application start time: 0x01d63cd19c62071c
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Phoenix\AoE2DE_s.exe
Faulting module path: C:\WINDOWS\SYSTEM32\CONCRT140.dll
Report Id: 518feff9-6142-4ed7-afbe-52bbd6eb6a3e
Faulting package full name:
Faulting package-relative application ID: