Crash to desktop due to low VMEM

Happens within seconds during tutorial mission. Reliably.
Managed to beat the first norman campaign mission, but crashed on the second.

Log from window event viewer

Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: RelicCardinal.exe (16540) consumed 13840916480 bytes, vmmem (21808) consumed 9483137024 bytes, and firefox.exe (11580) consumed 2396450816 bytes.

System is an intel 9900k, 3080 and 32GB of ram. Playing on steam.

Tried to close firefox and I think that helped. Far be it from me to say how much a memory a game should use, but it shouldn’t crash. No other games installed on my machine do.

3 Likes

Doesn’t vmmem refer to your pagefile as opposed to RAM? Odd that anything is being paged at all considering you have 32GB of RAM.

VMMEM refers to virtualised machines subscribed memory. In this particular case likely docker.

I don’t follow. Are you playing this on a VM?

No, vmmem is just another process that’s running on the computer, like firefox and aoe4. vmmem != virtual memory or pagefile.

Problem is game takes too much memory and crashes. I don’t know know how someone with 8GB or 16GB of ram is running it.

I have 32GB as well and it’s running just fine for me. Never had a crash even during closed beta or stress test. Did you close any unnecessary background apps before playing?

Just saw something else in your extract. RelicCardinal was the name of the executable for the pre-release versions. It should not be called that with the released game. Did you follow their instructions for uninstalling the beta / stress test before running the release version?

  1. Like I mentioned, closing firefox helped. Still, this is a high end computer. I shouldn’t be closing tabs to run this game. It literally crashes within 5-10 seconds into the tutorial mission - the lady can barely finish the first sentence. I would open a ticket to devs if I knew how. No idea if more demanding missions would cause it to crash. It’s clearly a bug.

  2. I was not part of the pre release/beta stress test. Literally bought the game a couple hours ago.

1 Like

Then I have no further suggestions, other than to use this link.

EDIT: Which you already, did, sorry. Wait for a response from the devs, I guess.

Where you running WSL2 while playing?

My game also crashes after 2-3 minutes in the tutorial.

My specs are i5 4570, 12 GB ram, 1060 and also playing on steam.

This is the error description from the windows event viewer:
Faulting application name: RelicCardinal.exe, version: 5.0.7274.0, time stamp: 0x616a2b32
Faulting module name: RelicCardinal.exe, version: 5.0.7274.0, time stamp: 0x616a2b32
Exception code: 0xc0000005
Fault offset: 0x00000000033d9e97
Faulting process id: 0x77c
Faulting application start time: 0x01d7ccf6cd1e07ec
Faulting application path: G:\SteamLibrary\steamapps\common\Age of Empires IV\RelicCardinal.exe
Faulting module path: G:\SteamLibrary\steamapps\common\Age of Empires IV\RelicCardinal.exe
Report Id: 660038b7-abd6-45b2-aa51-3d4143b9f102
Faulting package full name:
Faulting package-relative application ID:

Same here, but how do I check my Event viewer? Mine crashes without any error but also after 10-15 seconds after start of tutorial. Weird thing is that I can play custom games. My Campaign also has the issue, but at random moments.

I have solved my issues by increasing the virtual memory of the C drive and the drive I installed the game in. Not sure which actually fixed the issue.

The values that worked for me:

For C drive:
Initial size (MB): 8500
Maximum Size(MB): 10000

For the drive, the game is installed in ( in my case G )
Initial size (MB): 12000
Maximum Size(MB): 16000

1 Like

Cool il try that, I just did the tutorial again with task manager open, running on the lowest graphics now. It now made me play a little longer in the tutorial, but crashed again. What I saw was my GPU spyking to 100% right at the crash, then going back down. while the rest of the time it was running at 2 to 5 %.
So seems a video memory bug for sure. I run a MSI Ventus RTX 2060.

Just tried your solution, no more spike! Solved the issue for me.
Did first try it at low graphics though.

I had only a 1TB drive though, so put it to what I had left, 7000 min - 7500 max.
But issue solved! Hope they can patch this.