Crashes while loading into match 1 out of 4-5 games

I have had this issue since launch. Single player games are absolutely fine, load quickly with no lag. But when I que with my friends for Quickmatch or Ranked match, I have about a 25% chance to crash during the map load. The game makes no sound, no error code, nothing… Just crashed to desktop immediately. Since we have no reconnect feature, this results in an immediate loss for my team so they usually just back out and we all lose ELO.

My PC is more than capable, 5600x and 4080 with comparable quality across the board. I have made sure every driver is up to date, and have even replaced my PSU and GPU since the crashes started and it did not make a difference. No overclocks either.

I have tried running as admin, completely wiping (including deleting game file) and reinstalling, moving the game to a different SSD, turning off virus protection, completely reinstalling windows… pretty much anything a forum has mentioned if you google “Age of Empires IV crashing”.

I have the game on both Steam and Xbox Game pass, it will crash on both. Wireless or wired internet connection makes no difference, and I live in a city with good speeds and solid connections.

The only way I have found to rank up without dropping is to use my girlfriend’s PC, which has almost identical specs to mine. 5600x and 3080 TI, which is what I had when I started playing this game.

Has anyone else had this? I’m truly at a loss of what to do, I feel like I have tried everything.

Hey @TotalEclips3! Sorry you are experiencing this. Best thing to do would be to please contact support with your DxDiag and warnings.log file after a crash so we can take a look.