Crashing in Civ Selection Screen

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.53347.0 7314341
  • GAME PLATFORM: Steam, tested with/without mods
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


When selecting civ in a multiplayer or standard game lobby, the game crashes after clicking one. Campaigns so far no problem though.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Boot up a standard game.
  2. Pick a civ (may need to test if certain ones are causing trouble.)
  3. Crash to desktop.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The game plays normally…

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

The moment I click Byzantines (as an example), the game crashes. Try any other civ and it’d probably also work.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Hi @PunchingBagz!

This is an extrange issue :thinking:. Could you provide to us more info? It is not happening on our side.

  • Did a message show up when the crash happened?
  • Did it happened when you clicked on “Byzantines” or in “Confirm”?
  • Is it happening all the time? With all civs?
  • Do you have the log file generated after the crash? Maybe here? C:\Users\Usuario\Games\Age of Empires 2 DE\logs


Hi, sorry for the super late response. I forgot about this post for a while.

  • No message showed up, just crash to desktop.
  • Crash happens when I click the civ icon (in this case Byzantines).
  • It seemed to happen with the other civs I tried like Portuguese, Vikings, and Vietnamese. But I haven’t tested with every civ.
  • I have a few log files in the folder you showed. Hopefully you can figure out what’s wrong in them even though this is no longer the latest version. There were some mods active in the one I listed though so if you could identify which ones were the problem I’d also appreciate that.

2021.09.26-17.26.56.txt (7.4 KB)
2021.09.26-17.56.32.txt (6.7 KB)
2021.09.26-17.57.38.txt (6.6 KB)
2021.09.26-18.01.59.txt (15.2 KB)

Sorry, I forgot these other log files in case you need these ones instead.
AoE2DESteam-53347-2021.09.26-17.55.59.mdmp (277.1 KB)
AoE2DESteam-53347-2021.09.26-17.57.18.mdmp (307.7 KB)
AoE2DESteam-53347-2021.09.26-17.58.13.mdmp (318.4 KB)

Hi @PunchingBagz!

Thank you for this files and extra info! We have created a ticket with them.

Have a nice day :sunny:

BTW, your username in Windows have special characters?

Any non-utf characters could be a problem and results in crashes

I had exactly the same issue. Game crashes as soon as I click a civ in the civ selection menu. In my case it crashed with Malians, Malay, Spanish. I also noticed you have the same Original main menu UI mod that I had. I disabled it and everything worked fine after.

1 Like

Really? I’ll try again without it then - that was actually the one I suspected the least since it didn’t affect gameplay lol

Also @IkoKnight8151 no my username doesn’t have any special characters.

1 Like

Hi there, i have the same problem, today will be the fourth multiplayer game that i can’t play. As soon as I try to choose civilization, the game shut down and go back to the desktop.