Ctrl or Shift+Extra mouse button bugged

Game Version:

  • Build: 101.101.36202.0 4819260
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Strategerist

Issue:

I can set my select all idle villagers hotkey to ctrl+Extra Mouse 2 or shift+Extra Mouse 2 with no problem and it shows as expected in hotkeys. However, it does nothing in game. I have checked and there is no overload issue. Also Alt+Extra Mouse 2 works fine, so it shouldn’t be the mouse issue.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Set “Select all Idle Villagers” to ctrl+Extra Mouse 2
  2. Enter game and attempt to use it.
3 Likes

Still happening! :frowning:

Wow, almost a year and no fix :-(. Shouldn’t this be a simple fix…

Still an issue. While we are waiting for this to be fixed, can be worked around by setting your hotkey to alt+extra mouse 2 and dropping
^XBUTTON2::
Send, !{XBUTTON2}
return
for ctrl
or
^XBUTTON2::
Send, +{XBUTTON2}
return
for shift
into a autohotkey script. Not ideal, but does the trick.

2 Likes

Hi bro,

I didn’t quite understand that workaround. Do you have a link with some steps to do it or something like that?
I would really appreciate it.

Thanks in advance!

Autohotkey is a free software that can do many things, but the use I describe is to catch your keyboard inputs to the broken hotkey (ctrl + extra button 2) and remap them to unbroken hotkeys (alt + extra button 2).
Steps:

  1. Set the hotkeys you desire to be ctrl + extra button 2 to alt + extra button 2 (which DOES work).

  2. Download and install autohotkey (autohotkey.com)

  3. Create a new ahk file
    a. Open windows explorer and go to a folder of your choice
    b. Right click and select new->AutoHotkey Script
    c. Type this at the bottom and save:
    ^XBUTTON2::
    Send, !{XBUTTON2}
    return

  4. Run the script by double clicking it before you start a game (only needed to be done once per turning on computer)

Optional:

  1. Add script to startup to run whenever computer starts
    a. click windows key + r, and type shell:startup to open startup folder or go to
    C:\Users\[Your User Name Here]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
    b. Add a shortcut to you script in that folder
  2. Make script only run when Age of Empires is running
    a. Add a line “#IfWinActive Age of Empires” directly above your “^XBUTTON2::!XBUTTON2” line (no quotation marks in actual code)

What the code does
^XBUTTON2::
Send, !{XBUTTON2}
return
^ - symbol for ctrl
XBUTTON2 - extra button 2
! - symbol for alt
:: - key replacement operator
{} - Tells the script XBUTTON2 is a button and not text
send - Indicates new keystrokes to send
return - tells it you are done with that function

So what this script does is intercept your keyboard strokes giving ctrl+extra button 2 and instead puts out alt+extra button 2, which is the non-broken age of empires hotkey that you set up on step 1.

Disclaimer: autohotkey is a scripting language that can do more things than I specify here. While the program is itself safe, don’t go downloading random ahk scripts from the internet and running them without knowing what they do.

1 Like

I also reported this months ago in detail, but back then I was experimenting with control group functionality. I wanted to see if it was practical to have your main groups in the mouse, so as to free up the lower numbers (I’m left handed but use the mouse to the right).

So I guess the problem is widespread through all hotkeys, not just control groups.

Thanks for the detailed explanation!

Tried it but it didn’t work, did i do something wrong?
image

Ok, it looks like you need to have this instead:
^XBUTTON2::
Send, !{XBUTTON2}
return

I was certain I had used the other stuff before and it worked. Weird

1 Like

Since the last patch it’s happening again

We are aware, thanks for pointing it out ^^

Is it gonna be fixed in the upcoming patch ?

I used auto hotkey to fix it but doesn’t work anymore. Any idea why ?

I just tried and AutoHotkey is still working for me in order to select my idle villagers with Shift+Mousebutton.

What uuuuuuppp, this is finally fixed!!!
Everyone else: “Look at this huge balance update”
Me: “NO WAY! They finally fixed the bug”
Good job devs

3 Likes