Cursor moving outside fullscreen with multiple monitors

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.1529.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

I have two monitors, and I am running AOE3DE on one of them in full-screen mode. When you use your mouse to navigate, you would expect to “scroll” when the mouse is near the window’s border. However, it seems that the application does not run in actual full-screen mode as the cursor can go outside the game to my other monitor, effectively disturbing the gameplay. A similar issue exists with AOE2DE but there you can click once outside of the game (on the secondary monitor) and then click once in the game (primary monitor) and for the rest of the game, it works. That fix does not work in AOE3DE.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: EXPECTED RESULT

When moving the cursor to the game window’s edge, the cursor should always stay inside the game’s window and when it nears the border of the screen the camera should move alongside the same direction as the cursor.

:arrow_forward: ACTUAL RESULT

The cursor moves outside of the game window, which makes controlling the game a real pain.

1 Like

Hi there! Thanks for this report. Have you tried adjusting the game options? This can be found by going to Options -> Game Options and then click “Clamp mouse to window” near that bottom of the menu.

I hope this helps!

7 Likes

ADragons solution is how I solved this problem as well.

1 Like

That works. Had not seen or expected that option! Thanks for the prompt response! I cannot find it in AOE2DE though. Does this work differently there? EDIT: I found it in AOE2DE and apparently I have had it enabled there. But as I said before, it only works for me there if I click outside the window once, and then inside again. From that point on the mouse is clamped. But that’s an AOE2DE issue, not AOE3DE. So, thank you for your reply!

1 Like