Custom Campaign - win conditions, scenario instructions and scout reports

Hello, I’m a noob with the scenario/campaign creator and have tried to use uncle Google but can’t find the answer.

I’ve created a series of custom scenarios, each with bespoke scenario instructions and hints etc as well as custom win conditions.

When I add these scenarios to a custom campaign and load in via the campaign; the objectives tab only ever defaults to “standard victory” conditions on the instructions tab. It shows my hints in a separate tab but not the scenario instructions or scout reports. Both the scenario instructions and hints display properly when I test the scenarios individually (but still can’t see my scout reports here).

  1. how to I get a custom campaign to retain (and show) the right victory conditions for the scenario I created?

  2. how to I get my scout reports to show at all?

  3. how to I get scenarios within a custom campaign to show their respective scenario instructions instead of default objectives for the victory conditions (which as per point 1 are wrong anyway)?

Thanks in advance for any help you can provide.

1 Like

@PhillySouljah, @BassiAoC You certainly know :slight_smile:

1 Like

You should open someone else’s scenario in the scenario editor and take a look at their objective triggers / setup and base yours on theirs. That’s really the best approach to take without seeing what you’re trying to do in your specific case. If you have active objectives at the start, the default Random Map objective message should not appear.

I have no idea why the Scout tab is not appearing. You should double check that you entered your text in the Scout section and not one of the others, like Victory or Loss. It is possible you put in the text and it somehow didn’t take so you should retry/confirm that text in the Scout field in the editor.


Thanks @Yorok0 and @PhillySouljah

Thats a really good idea re opening up someone else’s scenario to compare, I’ll give it a go. Re the scout messaging I’ll try recommitting them but pretty sure it’s bugged in some way as the text is defo there and the same thing happens in multiple scenarios.

Thanks again for your support - I appreciate it!

Hello Shiromari, I have a similar problem. Did you fixed it? How?

Hey @LeonTroglo . Point 2 was fixed by reinstalling the game. Point 1 and 3 I have found out are known bugs so no fix as of yet. That said, yoko linked me to a similar thread, so if a workaround is found I’ll link that thread here.

Thanks I’ll keep an eye on it.

Do you know by any chance where is displayed the “History” panel text ingame?