Custom map display not loaded

The custom map is not displayed, I put it in RandMaps folder, but it is still not loaded, below is the image.

Does anyone know why? Thanks in advance. :pray: :smiley:

You’ve put your maps files in the incorrect RandMaps folder. The folder you’ve used is for official maps and yours will not be displayed.

First, you’ll need to remove the files from that folder as you will have a conflict otherwise.

Second, put your map files here: C:\Users\user\Games\Age of Empires 3 DE[big looong number]\RandMaps


Thank you for your answer first, but I put it in this path, and it still doesn’t show


By “it” do you mean there’s only 1 file? Sounds like you made a scenario, not a map. A map will have 2 files, an xs and an xml.

If it’s a scenario, put it in this folder: C:\Users\user\Games\Age of Empires 3 DE[long number]\Scenario

The file type of a scenario is age3Yscn

Is a map pack collection, there are several custom maps, not the campaign, the previous version can be used, but the decision version I put in this path, but I don’t know why not show

Here is a screenshot

Do you have multiple steam accounts? Make sure you’re using the correct account for that folder if so.

I don’t have another account, only one steam and user account

Custom maps are usually available in previous versions, as well as in final versions. But now I don’t know why it doesn’t show, can I upload the file to this webpage, and then you can download it and try it?

I just did the same procedure and if I manage to install my rms collection. Could you try this alternative? Go to the mods\local.

Then create a folder inside local, example “My xs collection”. Inside “My xs collection” create another called “RandMaps” and place your generated maps there. (All without quotes for obvious reasons). If this persists check if you have another folder with many numbers in “C:\Users\user\Games\Age of Empires 3 DE”

The last thing that occurs to me is that you have to take a look at the xml of the maps.
PS: Make sure the mod is activated.

Thank you. I’ll try.

I tried but I still couldn’t. The mod is displayed, but the map is still not loaded. Map files are available in previous Empire 3 versions. But DE does not know why it is not displayed. Here’s the picture

There are no other digital folders in the root directory. Custom maps were available prior to classic version 1.03.


Thank you. Earlier I put the file in E: Steam \steamapps\common\AoE3DE\Game\RandMaps. I forgot to delete it, so I don’t show it. Now I will delete the map file and put it in C:\Users\user\Games\Age of Empires 3 DE[big looong number]\RandMaps. It shows. Thanks for the answer! :smiley: