Customizable Explorers Removed

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 13.4412
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I have lost the customizable explorers for the Chinese, British, and Spanish, despite having done all the challenges and unlocked them properly.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

No steps to reproduce. It’s just been removed from my game, despite having an Xbox Live account.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

I should have full access to the three explorers for the Chinese, British, and Spanish. You can even see that I’m using Captain Huang, instead of Laochen, and you cannot skip Laochen and go to Captain Huang, he was a prerequisite to unlocking Captain Huang.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.

Hi, the same happens to me from time to time and I fix it by selecting the skin of the explorer that comes by default, i mean the legacy, (In your case you have selected an alternative that was given in a previous event) Don’t be scared if this also gets blocked, followed by that i just restart the game a couple of times and all these are unlocked again, make sure steam cloud sync your files, If you feel unsure about doing this, make a backup of your AoE 3 savegame files.

C:\Users\ username \Games\Age of Empires 3 DE

If the problem persists or worsens, try to continue contacting support to find a solution.

1 Like

It actually fixed itself just like you said but it took like 24 hours. The night I discovered it I restarted the game like 9 times, restarted my PC once, nothing worked, and it just magically worked. Must be just a glitch and not like a major bug.

Es mas un error de sincronización de steam cloud a mi igual me ha pasado

Hi, thanks for all your reports. Glad it fixed itself! Could be a steam synchronization error. Maybe the fix is to try fully logging out of Steam and Microsoft accounts, and then restarting things until it works??

I’m unsure what it was, but it’s fine now and I am currently enjoying the new Italian and Maltese explorers as I try to finish all the challenges.