Dear AOE:DE and Microsoft, can you please fix the servers so that they stop crashing?

Game Version:

  • Build: AOE:DE Build # 46777
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Rakovsky


Dear AOE:DE and Microsoft,

You have a really fun game. But can you please fix the Multiplayer Lobby and Servers so that they stop crashing? I keep getting crashes and I know that I’m not the only one.

I’m using Windows 10 on a new computer and a good internet connection. About 30 minutes to an hour into my matches it’s typical for the Game to say that I got “dropped” from the Server or that the Connection to the Lobby was “lost.”

I know that other experienced gamers have to pick through the Servers (eg. US Region vs. South India) to find one of them that will hold a good connection.

It seems like this should be a relatively simple problem to fix because AOE1:DE is probably one of the simpler games in terms of memory usage. It’s more like playing chess than playing the graphics-heavy Battlefield I or V, which must take tons of memory. By comparison, Gameranger and Voobly are relatively solid reliable platforms, but they just run AOE:ROR, not AOE:DE.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Create a Game Lobby Room in the Multiplayer Servers.
  2. Play a Game with a Couple people for an hour.
  3. Do this 4 times a day with each of the servers.


How do I make or find a DXDIAG or CRASH LOG on my computer to send you?


Step 1: Open File Explorer and go to C:\Users\youruserid\Games\Age of Empires DE\Logs.
Step 2: Filter to show the latest files.
Step 3: Open the latest log file.

Note: It would be a good idea to upload the startup log too.


Over the last two days, my Custom Scenario Multiplayer matches keep failing to connect. Another Player on Discord told me that all Custom Scenarios are bugged in AOE:DE since the last Update and won’t work.

Trying to host a match with three of four people caused me a problem where after I clicked to Launch the game as the host, an error screen appeared saying that the server was waiting to connect to the other players, and the screen just lagged at this. I am attaching a screenshot of the screen.

When I played with the fourth person, we were in a group match (actually there were 6 Human people total in that match, including myself) and after 20 minutes, the Yellow player resigned, followed soon afterwards by the other players, even though there had been hardly any fighting. When he resigned, I noticed that the Yellow Player had NO units or buildings. Of course, it’s possible that his buildings were destroyed in fights that were in my fog and the rubble disappeared before the game ended. But it would fit the pattern of the game being bugged.

Here is my latest log file.

2021.07.02-14.27.46_base_log.txt (27.9 KB)


I have a problem where lately my AOE1 DE game stalls out at the loading screen when I go to play a 3 v 3 Multiplayer match on a Custom map I made called “Land of Canaan.” I tried playing the map as a 3 v 3 on 6 total occasions, and it used to work. But this week on the 2 times that I tried it, it stalled out at the loading screen. Then after waiting long enough, it gives me the message that it dropped because of a sync error. My internet connection is fine and I have the latest “build” of AOE1 DE, 46777. I heard that this is a known problem on Custom Maps.(edited).

I thought that the problem could be related to choosing custom maps or to choosing the hosting server region. I was using the West UK Server. Months ago when I played with gamers like Daunting Knight, they emphasized that the West UK server was the best regardless of your home region (I’m from the eastern US).

1 Like

Unfortunately, not only on custom maps. It is a general problem. But certainly for at least a year now.
Why can you hardly find games in the lobby? :thinking:

1 Like

I wonder what the cause of the problem is in terms of the server’s settings. AOE ROR is a 20 year old game and yet it runs fine on Gameranger and Voobly. Months ago, I was also able to run my “Canaan” and “Mideast” maps fine on the Multiplayer Servers, but I practically can’t host them now due to the lagouts.

I think that’s where we need to ask Microsoft. It’s probably a problem that causes a conflict between the game and the servers.
The fact is, if this were to occur in AoEII, a hotfix would come so quickly that you’d be willing to look it up at Guinness.


I like your humor. Microsoft certainly has the ability to fix the problem.