Desyncs Occurring when Spectating Downloaded Game Recordings of (Land) Nomad Team Games

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.56006.0 7694700
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Lately, if I try to spectate recorded games that have a nomad start (I haven’t tested it with water nomad but wouldn’t surprise me if it happens there too), the game desyncs while spectating as early as 30 seconds in; sometimes it takes a few minutes. It then gives an error message stating that the game has gone out of sync. I came across this bug before, and it was worse then: the error message would pop up multiple times, each time with a different ‘world time’ number. After clicking the window away about 5 times, it would stay gone. I wasn’t able to reproduce this last issue, however, when I tried to get some footage just now.

I ran a few tests to see what triggered the bug. For one, I tried downloading a random selection of land nomad and nomad games from, most of which were played today. The same issue occurred for each and every one of them, regardless of when they were played. Another thing I tested was with games against the AI. If I made a Single Player game on nomad against the AI (4v4), no error occurred when spectating. However, if I hosted a multiplayer lobby and filled it with AI, I would in fact get an error message when trying to spectate the game rec.

It therefore cannot be a game version issue which plagues old replays. Instead, I think it is related to the 5-min treaty system that was recently implemented. First of all, when I spectated a land nomad 1v1 (which is in the map pool right now), the issue does not occur. Secondly, I’ve never encountered this issue before while spectating replays, so I assume it is a recent one. This leads me to suspect that the 5-min treaty at the start of the game is somehow breaking team game replays for nomad maps.

I’m of course, not 100% sure since I’m not an expert on these matters, but the clues seem to point that way.
I hope I have done enough in the way of testing this to make the issue clear.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Go to
  2. Download a random recent nomad/land nomad team game
  3. Spectate the game
  4. Wait until it gives an error message (might take a few minutes)

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Well, ideally I would be able to see the rest of the replay :wink:

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

(It’s a video. I didn’t attach a game recording because you can literally take any random one, and the problem can be reproduced).

Thank you!

Hello, this is luckily already tracked issue, thanks for the report nonetheless.
Have a nice day.

1 Like

Ah, perfect. I must have missed it in the list. Thanks for responding!

There is one more thing: the timestamp of the recorded game appears to be about 5 hours in the future.

It’s funny to see how a recorded game is “about to happen in a few hours”.

I tried to change the date on my PC, but the recording still goes out of sync.

1 Like

Hi again @UltimaGaina !

Thanks for pointing out his timestamp issue, we are now tracking it (≡^∇^≡)

1 Like