Difficulty Level Condition can't acutally use value "Extreme" (Not Fixed with Update 37650)

Game Version: 101.101.36906.0

  • Build: 4941835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: MrKirby

:bangbang: AFTER UPDATE 37650 :bangbang::

Same behaviour as before this update.


When using the Difficulty Level Condition when selecting the Extreme option, the effect will become ‘unvalid’ (red) and will reset to Level Standard.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Create trigger
  2. Create condition Difficulty Level
  3. Set Difficulty Level to Extreme and watch it be invalid


Here you can see six conditions. All with different difficulty levels: Easiest, Standard, Moderate, Hard, Hardest and Extreme respectively. Only the Extreme Condition is marked invalid.


This has not been fixed yet. It’s been ~5 monhts. Please fix this!

This issue has not been fixed with Update 42848.

This issue has still not been fixed with (1.5 month old) Update 47820 .

This exact issue has been fixed. The scenario does now save it properly. Though, that being said, it still doesn’t actually function ingame. Difficulty Extreme always fires for any difficulty set…

This new problem (“Extreme” difficulty not working properly) is now tracked on our side, thank you for the report.

1 Like