Disconnected From MP Servers for SP Game

Game Version:

  • Build 35199
  • Platform Steam

Issue:

Game disconnects from multiplayer servers early game when playing a 1v1 PvE game.

Reproduction Steps:

  1. Start a random map game with one AI
  2. A few minutes into the game I was disconnected from the multiplayer servers.

First Game Screenshot:

Second Game Screenshot:

Thankfully I was not dropped from this 1v1 PvE game.

Third Game Screenshot:

Again, thankfully I was not dropped. Same 1v1 PvE format.

The multiplayer server maintenance today does not appear to have resolved the issue. Every single 1v1 PvE game I play is interrupted by the connection to multiplayer servers warning.

Hey RB! I want to start by making sure you’ve already updated all of the necessary drivers to run the game: including your video drivers, any Windows Updates, and VC Redistributables.

Beyond that, have you done any network testing with your router, modem, and anitivirus/firewall technology? There could be any number of factors that cause a disruption in the connection with the servers, so getting a feel for what you’ve tried will help us as we dig into the problem.

Thanks!

1 Like

Hi @GMEvangelos,

Checking my system…

  • I have the current Nvidia game ready drivers 442.50 installed.
  • There are no available Windows 10 updates. I’m on version 18363.693
  • I have installed this VC redist https://aka.ms/vs/16/release/vc_redist.x64.exe and it doesn’t appear to have made a difference.

What tests do you suggest that I run on my router, modem and antivirus/firewall? I have Windows Defender. Xbox Networking in the Settings app shows no issues.

XboxNetworking

Edit: Turning down all the graphics settings appears to resolve the issue. This is surprising to me because my system with an i5 8600 CPU, 16GB DDR4 RAM, 500GB SSD and Nvidia GeForce GTX 1060 6GB GPU should be able to handle this game without an issue. It appears that AoE II: DE players are experiencing the same issue, so I’m inclined to think that the issue has nothing to do with my system. I did not have this connection error issue until the most recent update to the game.

What I don’t understand is why a multiplayer server connection is now required to play single player games at all. :thinking:

I ended up resetting my router and creating a new network key. When my PC was the only device connected via a wired Ethernet connection I did not have any disconnect errors during gameplay. Adding many devices to my wireless network did not produce any disconnect errors either. The only thing which appears to have reproduced the error was another member of the household playing a game on the internet at the same time as me.

After more testing and looking through my wireless router settings, I was finally able to play a single player game at maximum eye candy settings by enabling the QoS, Quality of Service, setting on my router. Since that time I have not received a connection error during a single player match, even when another member of the household was playing a different online PC game, the Java version of Minecraft.

Well, I thought this issue was resolved. After server maintenance today the issue has returned. :frowning_face:

Edit: I revoked our Google Home Mini and my son’s tablet from our wireless router admin console and all is right in the world again, so perhaps there is a conflict with the Google Home Mini or my son let YouTube videos play on his tablet once his screen time expired for the day. I’ll keep testing.

I had the same issue yesterday. In SP and editor-mode. But I could keep playing. I think that is a problem from the Microsoft servers.

I’m still experiencing this issue. I hope a new wireless router will resolve it by the end of this week. My current one is 7 years old and may be the source of the problem.