Don't select 'dancing' Warrior Priest when 'Select all military units' hotkey is pressed plz

I keep selecting them, removing them from the new firepit thingy. Which is really annoying.

So can the ‘dancing’ Warrior Priest not be selected when the ‘Select all military units’ hotkey is pressed?


Any solution yet ? searched all over internet for this still no option

1 Like

I have this issue when playing INCA man… Why do Priestesses count as MILITARY UNIT ???

@RolingStones698 My solution is to hotkey them as a group but I always have to put them back to the Fire Pit when I select my whole army. It’s so annoying. Devs do something please

1 Like

When I want to move all my military units I use small button next to minimap. That way Warrior Priests will stay in the Plaza and others will move. I’ve done it hundreds of times and it always works fine :slight_smile:

I would like the button to also not apply to building wagons. It’s very annoying esp. If I have already placed the foundation elsewhere.

That works for Aztecs but not for Inca. Trust me. Go play Inca and you will always find your Priestesses joining the army


I feel the same. If the problem is solved I would like to play Aztecs.

1 Like

While this issue is fixed for Warrior Priests (at least I’m not experiecing it) it is still present for example for Healers (and probably for Priestess too). Devs, please don’t treat them as military units.

1 Like

Throwing this out here also, the French revolution with the sans-culottes grabs your entire economilitary when you use the grab-all-military button.

I kinda feel like this should be addressed too since it’s kind’ve an eco-revolution.

My dream is that this field hockey will not affect native scouts and trackers.

Would be amazing if it could be customised somehow.