Double click problem

In this update, when I do double click in a unit or building, then select all the units or buildings, but of all the MAP!!

I checked the options because I thought I could disable it, but I didn’t find any option that will disable it.

This is stressful … before, when you double clicked on a unit, it was just the ones on your screen.

Can someone help me?


I just tried to confirm, but this seems to be a problem on your end :confused:
Any mods installed?
Please try to reset the options of the game and redo them.
Maybe verify the game files ?
To be absolutly save, consider reinstalling the game and deleting the following folders: "
C:\Users\ [Name]\Games\Age of Empires 3 DE\ [Number]
Users "

I have the exact same problem.

I have no mods installed, my game version is the latest Windows store version.

I have this exact problem since last month (never had it earlier). What’s going on? I thought it was my mouse. But different mouse still same problem. I stopped playing for weeks but used my computer regularly and never had the double click problem. But once I try to play the game, I run into this problem. I still have this problem.

I tried all of these but the problem persists. Definitely update related. Lots of people are having this problem. They should care a little bit about Age 3.

1 Like

Yeah, I have the pup and it fixed the issue ( also in the patch notes) so with dlc release its fixed!


Yes, problem solved, thanks!

1 Like