Error message "no download url available" with updating mod

:arrow_forward: GAME INFORMATION

  • BUILD #: 4#####
  • PLATFORM: Steam / Microsoft Store
  • OS: Windows 10 / Windows 7 / Mac / Linux

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

I am trying to update my mod “roll the dice” to a new version and i get the message: Failed updating mod Error: no download url available

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. go to my mods
  2. click update mod
    3.update now

I’m thinking the error is not on my side but on the server.

1 Like

I’m also getting this message when trying to upload my mod to a new version. Doesn’t work in-game nor through the website.
Also unable to upload the mod through a different name.

Let me know if you find a solution

1 Like

Ok, glad its server side and not the client. They will fix it then.

@DodoNotDoDo Users are having troubles updating their mods.

Yes, there’s currently a problem in part of the publishing pipeline (outside my control) that’s currently be worked on. I’ll post here when I hear it’s fixed.

I’m trying to update an existing mod which is a scenario by using the Update Mods button in My Mods, but nothing happens when I click the box to select the mod folder?

its a server issue, got the same problem

i cant upload Mods of the type “User Interface” and many others. Only campaigns and scenarios are possible atm. Does anyone know why? I hope the Devs didnt do it intentionally…

I am having trouble uploading/publishing my mod as well…

The previous publishing issue should be fixed now. If anyone continues to have issues, please let me know!

publishing is working fine now but you cant update now, noone can download or updating my mod in the mod selection

It works now, unsubbing and resubbing did the trick!

1 Like

I just tried to publish a mod both in game and on the website, failed with this error message. Now in the “My Mods” page I saw both of them. One could be accessed: Mods Single - Age of Empires and the other cannot: Mods Single - Age of Empires. But I can find neither of them online in game, in Mod Manager.

I tried to delete the duplicate one, but after a refresh it’s still there.

@DodoNotDoDo What’s going on?

It looks like the Azure outage yesterday caused the service to break. It’s since been resolved, so things should work normally again now. It looks like both mods you reference were deleted.

Yeah it took maybe half an hour to validate a deletion, and publication. And any mod downloading is prone to fail today.