Error start AOE 2 Definitive Edition

Good afternoon.
I have the same problem with the GPU Intel HD Graphics 3000 with vendor id 32902 and device ID 294 is not Directx 11 compliant, i have de Directx 12 version and my GPU have 2GB of VRAM, just how it shows in minimum requirements.
¿What can I do in this case?

5 posts were split to a new topic: Game Crashes to Desktop

Se supone que el error que da es este:

GPU Intel ® HD Graphics 3000 con ID de proveedor 32902 e ID de dispositivo 278 no es compatible con DirectX 11

Que significa que no es compatible.



I have the same problem, the minimum requeriments shows that HD Graphics 3000 is compatible, please fix that problem!!!

We recommend updating your drivers and checking with the website for your GPU company.

I already updated the drivers and checked with the GPU company and the problem persists

I am having the same problem and also get the message: Failed GPU startup:
Intel® Graphics GPU with vendor 32902 and device ID 258 is not DirectX 11 compliant. Other games work fine but not AoE2 DE. Please help.

Check out the link here for some possible tips:

tendgo el mismo error. Lo pudiste solucionar?



Una consulta. A mí me sale el mismo error: intel® hd graphics gpu with vendor id 32902 and device id 70 is not directx 11 compliant.

Llegaste a solucionarlo?


I have the same problem
my windows version is 1903 Home edition
Processor Intel Core i3 m370 @ 2.40 GHz 2.39 GHz
Operative Sistem 64 bits, processor x64

I can’t run the game

Age of Empires’s not compatible with Intel HD 3000.

Microsoft and his incompetent team and moderators can’t just say “hey, sorry, we made a mistake, intel hd 3000 is not compatible with our game”.

I have the same issue using an hybrid (igpu, dgpu) driver that supports Dx12.

Same problem – I have DirectX 12 installed but somehow not DirectX 11 compliant?

Hi, yesterday I bought Age of Empires II Definitive Edition for Windows from Steam. When I start the game the following sentence appears: “Intel® HD Graphics 3000 GPU with vendor id 32902 and device ID 294 is not DirectX 11 compliant”, but in my PC the DirectX 12 is installed. Please, can you help me?

Hi @Totino54, While it is true that Windows 10 supports DirectX 12, you need at least a DirectX 11 compatible GPU to run the game. The Intel HD Graphics 3000 GPU supports DirectX 10.1.

Since we are a bunch of dudes who got the game with lies, is there a possibility for a refund or what can we do?

1 Like

It’s sad to know that I spent a whole evening researching different graphic drivers and how to get the game to work and in the end I find out that I can’t even play the game :frowning:

I know well HD3000 graphics is not supported. But I have a HP DV7-6195us good laptop with Core i7-2630qm 4/8cpu (HD3000 integrated graphics) + AMD HD 6770m. They work as switchable graphics. In power options, in Intel settings and in AMD settings everything is set as Performance. Also from Control Panel/Programs/Windows Settings/Legacy Components/DirectPlay is enabled.

I spent too many days and tried too many different AMD drivers, also I installed Win8.1 and Win7 again. None of them helped.

If anybody knows a solution to make AoE:DE believes that I really have a dedicated graphics card, which I really have:6770m, please somebody show the way.

This forum is my last hope.

I had a dell optiplex 990 SSF PC, I used to get the same error. I got a new graphics card (GT 710 2GB), installed the driver and the game started running. Costed me $50.