Eternal Gratitude Achievement not Working

Game Version:

  • Build: 101.101.36202.0 4819260 (14-04-2020 build)
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: wormstaart


When finding the Penguin in the Vinlandsage mission the “Eternal Gratitude” achievement is not achieved.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Start mission (tried in normal and hard difficulty)
  2. Build a transport ship
  3. Go to location of Penguin and find the Penguin
  4. Did not receive the achievement “Eternal Gratitude”




I have also been unable to get this achievement in build 101.101.42848.0 5818516

1 Like

I have the same problem with steam in the build 101.101.42848.0 5818516 too. I have tried to obtain it in diffeent difficulties…

1 Like

same for me :frowning:
in hard mode

1 Like

same here :frowning:

1 Like

Still a problem: I can’t get it neither.

1 Like

Same story here. By the way, I think that it would be actually easier for such type of bug reports to make a poll as a counter in the very first post, to eliminate the need for people to agree on the same thing in the comments. Like this one:

  • Yes, I encountered the problem.

0 voters


i have the same problem i play on steam with the last update and i can´t get this chevoo on my xbox gamertag and The King Is Dead, Long Live the King! is buggy too

1 Like

Same here, hard difficulty on latest version -

Ima trying to get all achievements, Found the badass penguin - nothing happened…

1 Like

Same thing here playing on the November 24th 2020 build. Achievement did not unlock in any game difficulty.

I literally have just this achievement left for 100% on steam and it won’t unlock for me! AoE Devs, please help!!!


If you do the math… I have the penguin selected, yet not achievement unlocked. “So close…”
What a freaking troll.

Still unable to get this achievement. Why can’t the developers fix these very simple bugs? Do they not care?

Decided to try and go for 100% achievement for AoE2, but for the moment that is not possible due to this achievement being bugged.

I just played on standard and hard, saved the penguin and kept it alive all game. Achievement did not trigger.

Played on Steam version: 101.101.43210.0 5867313

Fixed! Finally! Got it today! :slight_smile:

“Chasing the Crown” is also fixed.

Played on Steam version: 101.101.44725.0 6115729


Yep, confirmed - fixed on latest patch!

Go get that penguin!

1 Like