Extra attack on projectiles may be falsely recalculated

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 62085
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

(Sorry, english is not my native language).
The issue is about bad attack value calculations.
It only affects units that use projectiles (either melee or pierce damage, however range unit without projectiles like Kamayuks are not affected)

For any unit, the graphical display of its attack is made of two numbers: base attack and extra attack. The base attack is specific to the unit line itself, while the extra attack depends on numerous factors, most notably blacksmith upgrades. For an example, a post-castle age generic knight has 10 base attack and 2 extra attack, because of the blacksmith techs. Other technologies may also impact extra attack points. However, extra attack points may also be given by scenario trigger “Change Object Attack”.

This is where things got weird recently: for all projectile-throwing units, it seems that whatever extra attack they have, when the game must manage one hit from that unit, the displayed extra attack is completely ignored and replaced by what it should be according to current researched technologies. In most cases, this doesn’t change anything since the displayed extra attack should match your current researched technologies. Excepted in (at least) these two cases:

  • “Change Object Attack” trigger was used to change the unit’s attack stat.
  • You did not create that unit yourself. Either “Change ownership” trigger gave the unit to you or you converted it with a monk.

In these two cases, the extra attack may not match what it should be according to your tech tree, and that’s totally fine, it has always been like this since 1999.
What’s not fine though is the phenomenon described above, (displayed extra attack replaced by another value when calculating damage), because it cancels the effects of the two cases above, and I am 100% sure this behaviour is recent, because it was not existent 6 months ago.
(Following examples are backed with game files)
Example: if you’re in post-imp and convert an enemy chakram thrower without any upgrades, it should have 5 attack, 0 extra. At least, this is what is displayed. But when your newly acquired chakram attacks another unit, it does 9 damage instead of five. 9 because the +0 extra attack was hiddenly replaced by +4, coming from your blast furnace line techs.

For a while, I asked myself if this was a new feature instead of a bug. But I don’t think so because:

  • If it was a feature, the game would have displayed the +4 extra attack in the unit stats after the conversion was completed in the previous example. Unmatching graphical display and result is never done on purpose, it always comes from a bug.
  • The “Change Object Attack” trigger is now useless for projectile-throwing units. Whatever new attack stat you set, it’s going to get ignored and hiddenly replaced by what it should be according to technologies, even if the attack change you tried to trigger is displayed in the unit’s statistics. This is very problematic since it restricts our capacity to edit scenarios. In fact, this is how I found the bug. A scenario I made 8 months ago became suddenly undoable without any editing because a boosted unit became suddenly too weak.

Sad that I don’t know since what patch the game acts like this. But I suspect the latest one: 62085, because it solved the famous “mangonel delete glitch” (bad attack calculations when a projectile comes from a dead unit). I suspect that the fix created this new bug, but I’m really not sure. I also suspected my subscribed mods, but I discarded this possibility, since none of them were data mods and disabling all of them does not solve anything.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

If you produce the circumstances for the issue to happen (conversion or trigger), there is no chance that the game acts correctly rather than acting with the above behavior , so:

  • 100% of the time

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps of the simplest way to reproduce the issue:

  1. Create a scenario with player1 human , player2 AI without personality, both in dark age.
  2. Ont the map, put only one military unit for each player, close to each other. The p1 unit must be a projectile throwing unit (ex: archer,chakram thrower)
  3. Create a trigger “Change object attack” which adds +30 attack to the unit of player1 at the start of the game.
  4. Run the scenario.
  5. You will see that the big attack boost is well displayed in the p1 unit’s stats when you left click on it.
  6. But you will also see that for every hit the p2 unit takes, it is unaffected by the attack boost.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The player2 unit should be impacted by the attack boost, so it should lose roughly 30 HP or even more on every hit.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

The issue is hard to highlight with a single picture, that’s why the above description was stretched rather than taking a picture. However, the following aoe2record file below simulates it all.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

I just found a much straight forward way to experience the issue. Just start “A perfect martyr”, the last Joan of Arc mission. Go find the huge army awaiting for you. The issue will be reproducible since you are not the one who created the units of your army.

Take only the 16 arbalesters (your other units can retreat to the corner of the map). Lure the burgundians out of their walls by hitting these walls. Coustilliers will come out to kill your archers.

Now hit one coustillier with all your archers and see how poorly they compete. Each hit does only 1 damage to a coustillier! … even if it has 2 + 2 pierce armor and every arbalester has 6 + 4, which should do 6 damage per hit.

So the bug might be more brutal than I thought first. If it was only the extra attack that was changed to my tech tree, it would be 6 +1 so 6 +1 - (2+2) = 3 damage per hit, but it did just 1.

So here is what I think: not only the extra attack was changed, but the base attack was also changed to the one of the same unit line that matches how much I upgraded that unit line in my tech tree. Since this mission starts in castle age, crossbowman is not even researched, so the arbalester, displaying 6 +4, had in reality the attack of a post-feudal archer, 4+1, so it did 4 + 1 - 2 - 2 = only 1 damage to a coustillier.

1 Like

Hey @TwinRecord31416

Thank you for your detailed bug report!
We are already tracking this issue :wink:

Thank you @ConvertThis4915 for your fast reply! I have two questions:

Since I am new here, was there a way I could know that this bug was already being tracked? I looked up very fast on the forum’s bug reports but I did not see something similar. Did I miss something? I want to avoid a situation where I uselessly spend time on reporting a bug that is already beeing taking care of.

Also, being a programmer myself, I have an hypothesis on what is going on (I might be completely wrong haha):

Before 62085, projectiles had a pointer to the unit that threw it, so when it hits, the damage is calculated from the unit that threw the projectile… but this caused issues when the attacking unit died before the hit, since the projectile was then pointing to a dead unit. So the fix 62085 was that the projectile points to the unit line in the tech tree, rather than a specific unit on the map, but this has its own issue: any difference between the stats of the attacking unit and the stats that should have a unit of its line is completely ignored.

Am I close to the truth?

Hey @TwinRecord31416

There is no clear method to see what exactly is reported. It might be that this bug was reported on discord or steam, reddit etc. In this particular case, someone already reported this on discord directly to a colleague of mine.

I am not a programmer for this game so I can unfortunately not tell you the details on the inner workings of the game, sorry!

1 Like