Find a shipwreck and gather any supplies mission (Blood campaign, scenario 2) doesn't work

:arrow_forward: GAME INFORMATION

  • **BUILD #: 100.12.1529.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

After finding the shipwreck and gathering the supplies, the game didn’t completed the mission. I also gathered the supplies from the ottoman mosque, but nothing happened either.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

  1. Play the second scenario of the first campaign
  2. gather the resources near the shipwreck
  3. wait for the mission to complete

:arrow_forward: EXPECTED RESULT

The mission should be completed when gathering the resources.

:arrow_forward: ACTUAL RESULT

The mission doesn’t complete.

:arrow_forward: IMAGE & ATTACHMENTS

1 Like

Getting same bug in release version of DE

1 Like

Same problem ! 2 patch = no solution

Just playing through, I have this issue, real shame it’s still not fixed after all this time.

Hi @EntombedCurve02, sorry for taking this long to respond to you. But we’re now tracking the issue with this secondary objective. And thanks @Rossrox12 for bumping this topic!