Fire Glitches in Ismail 1, The Red Hats

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.30274.0 (#95810) 12466982
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Some buildings when burning, momentarily stop burning the moment the building enters/leaves LOS. Relatedly when the building is just at the edge of LOS, the burning stops completely. Relatedly the assets used for the buildings are different when they are in LOS, vs when they aren’t. I know there is a rule about one issue per thread, but I believe these are related issues which I will explain below.

As an aside, while I didn’t check to make sure that this isn’t also an issue elsewhere in the game or in different scenarios, I’ve never noticed anything like this before, but noticed this immediately when playing this scenario. I’m not sure if it’s exclusive to this scenario, a new problem, or an old problem i’ve never noticed before.

:arrow_forward: FREQUENCY OF ISSUE

I found two houses and a mill at the beginning of this scenario. I’ve tried this scenario twice, and both times the issues happened nearly every time. I will say that in one time I opened the scenario one house didn’t momentarily stop burning, and another time I tried the scenario, another house didn’t stop burning momentarily the first time it came into LOS, but all subsequent times. So I’ll say 99% of the time and move on.

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start “The Red Hats” scenario
  2. Move your troops to the northwest and west where there are two houses and a mill on fire.
  3. Move your troops so those buildings leave and enter LOS

:arrow_forward: EXPECTED RESULT

That the only change when a building enters and leaves LOS, is the lightness/darkness of the building.

:arrow_forward: IMAGE

This image shows that buildings that are on fire, don’t show their damaged sprite but rather their full health sprite when not in LOS.

This image shows that buildings that are on fire, do show their damaged sprite when in LOS

These two videos show one of the houses and the mill, momentarily stop being on fire when they transition for in los to not in los and vice versa.

Lastly, I think this ties a lot of this together. This image shows that if you have a unit positioned just so, where a building on fire is just on the edge of LOS, it stops burning entirely. I have a cav archer placed between the two burning houses and the mill, but the more northerly house that should be on fire isn’t.

It seems that as buildings that are on fire are passing through the los barrier, they momentarily transition into this “edge of LOS so therefore not burning” state which causes that momentary pause.

I’ll be honest, I’m not 100% sure if the buildings having the wrong asset while out of LOS is related to this other phenomenon of the building not being on fire when at the edge of LOS. It does seem likely to me that two fire + LOS glitches would be related, but I too am a developer, and I’ll admit sometimes two seemingly related bugs aren’t actually related to each other.

:arrow_forward: GAME FILES (SAVE / RECORDING)