FPS drop issues

I have 16 GB RAM, CPU Ryzen 3 3200G, and GPU AsRock RX 570 4 GB, when i played in early game, it almost normal, i got fps like 30-40 fps, but when the game run to late game, around 30 minutes, my graphic start lagging, its feels like only 2 fps, because its laggy, and also I have problem, when in my pc, its time in 35 minutes, but in my friend game, its already 37 minutes, and my command is waiting like 2 minutes. until the unit response to my command. so i need to pause until my game cacth up the times. I things it becouse the graphic, and i already try reinstall the driver, but still not help. please if there is some advice

1 Like

same problem here… 16 RAM, Ryzen 5 3600X, RX 570 8GB… I tried everything and still the game is stuttering a lot after castle age.

1 Like

is there any problem with the RX 570? because my friend that only playing with Ryzen 2200G with its integrated graphic didnt found this problem in his PC.

1 Like

Use after burner or the radeon metrics press ctrl+shift+o to see the fps, clock speed, etc, i am quite sure the anniversary patch is not even using the gpu’s like it should be.

Mine is a rx 5700xt, the clock speed is 500 mhz at max despite if the resolution is in 4k, that is nonsense, i have stutter, lag and delay at most commands, the game is unplayable and it wasn’t like that.

clcok is at 500mhz cause this game isn’t that heavy on GPU side.

when people get 2-3fps game, turn on f11 to see your real frame rate and it’ll show something much higher than 2-3fps. the f11 shows your actual fps which is what your UI fps count is, when game lag for w/e reason, either server, caused by patch, or caused by other lagers in same game with you, the game code is to throttle the animation but not your actual game.

not sure why they designed the game this way but most codes are written for dial up internet and internet speed was a much bigger concern than computer hardware 20 years ago for sure.

now times have changed, I have been told that it is possible to adjust animation throttle so that only lager feel the throttle when they lag everyone else. time will tell with future patches.

Well before the anniversary patch the clock speed was btw 1200ish, 500 mhz is just too low for any dx 11 app, the main menu is the most gpu demanding thing in this game using 612 mhz clock speed 11

f11 display the latency on the server and the fps, but i have lag while the fps remain the same.

what before/after dont mean 4k would require anything more than 500mhz. I could use intel iGP thats fraction of a fraction of my dGP’s performance and still watch 4k video no problem.

they may have mess up with the patch, for majority of players definitely is better. I have played with a few regulars known to lag and there are much less lag now, and I have already explained right now game is coded based off to throttle in game animation, which is the cause of the problem and needed to address, and this issue was there pre patch as well.

I got a RX 570 4GB and my game lags too much too since recently.
I can’t tell if this is due to last patch or last AMD driver 20.11.2 ???

The game is running 165 fps (1440p) and get HUGE drops every 1-2 seconds, this is not playable…

Before I can launch single mode games, 8 AI, 250 max pop without problems…

Still nothing new. Some drivers update don’t change anything. It’s from the game. It’s like the fps going crazy like 120 fps > 60 but ultra fast and there are much stuttering. It’s so hard to play withour getting an headache.

key words, “single mode”.

it is a known problem online server has a lot more issues than single player. when it is single player everything is based off of your computer spec. however once you go online, not only it is determined by your own hardware spec, also need to take account of other players AS WELL AS server.

Yeah Ok, but it was working before the latest patch, and an I7 8086k 4.8ghz, 32go RAM and a RX470 (not the best for the GC okkkk but AOE2), no, this is not hardware related… more bug related :sweat_smile:

1 Like

i guess you’d need to read it again to find out what was said :sweat_smile:

I know there are problems with ONLINE game, but there are problems with SINGLE MODE too.
The game played smoothly before the last patch. Now there is pikes at ~120fps like before BUT a a lot of time it goes to ~60 fps every 5s and there are a lot of stutter.

He got the same graphic card that’s why I posted here, I tested drivers from before the patch and newest drivers, nothing changes.

no problem in single player for us. you would not be able to explain why majority of player base in single player have no issue, but we could explain and say its likely something changed on your computer could be the cause, and ruling that out and simply blame the game is far from trying to get things resolved.

me and a buddy of mine always make backup image constantly because we simply do not trust windows, or any 3rd party software that we install due to some core files may change that result in issue with other application needing similar files. usually when we run into problem, it is resolved with re run of the previous image that we knew it was on working condition. it is much easier to find the issue rather than have no idea where to go, could be the game, could be the computer, could be windows, could be a lot of things.

…or the game’s code for SOME graphics cards or CPU is broken on the latest patch ?!?
I know how to use a computer, I know how to diag things. I can’t go back on the previous patch in AOE and it’s the only thing that I can’t test. I removed most things that is running in background (not a lot) except windows things + amd, nothing, I put older drivers, nothing changes, I reinstalled the game, no luck (integrity from steam OK). I’m sure there are a lot of people that don’t have problems in SP, but I see that there are some, and a lot of time this is an AMD Rx***.

Backup image are usefull but :

  • You have to test them often
  • You have to think to do it each time (auto mode is not always good, you can forgot to do it for some things, windows update in the background, steam update in the background…)
  • You have to get space on a separate disk

… anyways the game was fine until last patch for me. The update broked it for me, I can’t tell with all my tests what other think may broke it and between the game update and me playing it, 99% sure that there isn’t others changes in my pc. So I hope the next patch will resolve MY problem. There are problems that impact every user, there are others that impact some users. Like… Cyberpunk for example :joy:

could be, while claiming you know for sure whats going on, you’d have no way to prove it is for your gpu or cpu. im sure there are others out there have similar generation hardware and they have no issue. and you couldn’t seem to get your GPU straight, first a RX570 then RX470, is there even a 470 or is that a typo?

there is a thread with few people having problems with gtx 3000 series, you can start a thread with RX570 and see how many people have problem with it on that generation of GPU, that would be a good start dont you think?

  • No I dont need to do it often, only when I have issue will I restore.
  • well this maybe one problem, you have windows update, and I don’t, didn’t I mention I do not trust windows? as it can change your core files without you knowing.
  • additional space is a tiny sacrifice for having the convenience and control of what I can get. claiming to know computer should at least know giving up control over some disk space is a no no.

cyberpunk is cyberpunk, and the issue came to light how it is coded improperly to not fully take advantage of newer CPU. your CPU has been the same architecture since sandybridge, which is close to10 years old. to even suggest that game code could have a problem with your CPU is simply absurd, because it would apply for intel gen 2 all the way to gen 10 CPUs. this is not even adding onto the fact game is on a 20 yr old engine. if its GPU, you MAY have an argument.

the cyberpunk argument doesnt really work well in your favor here, it’ll do you best to leave that example out.

I don’t know what is causing the problem, I tested a lot of things but I’m not a developper, I can’t tell this is "this module, this file, line 9805, “;” is missing where it’s commented “AMD RX series GPU”. I can’t tell if they added some functions with the last patch that use more power from the GPU, I can’t tell if there is a bug in their engine that activate something sometimes, I can’t tell if there is an incompatibility with a program, when my background programs are Steam, AMD drivers, Microsoft default apps… (lel). I can go on. And of course, because I can’t get the previous version of AOE2 DE, I can’t confirm either that this is 100% the patch that is causing problem.

Please… of course not I got a ATI Rage pro 128mb. It’s a RX570 sorry for my mistake, I hope my credibility is not next to 0 after this :frowning:

I think I already started a thread here, but I don’t remember well because it’s been 2 month since my game (when the patch was deployed :heart: ) is not playable correctly. Even my profile says 6 topics created and I can only find 3, I suppose it was deleted for whatever reason. I will recreate one yes.

You are maybe one of the 0.1% of users that do “everything” himself on your PC, no windows update etc… cool for you, I hope you do the updates of your PC by hand. Also the concept to control everything on his PC about updates, etc. and not trusting a tool when you use it is not very common sense. I hope you don’t recommand this behaviour to people who don’t know how to use a PC. In fact all the PC I repaired from my relatives, was because they shutted down PC during updates, installed a lot of bad software, used Ccleaner badly or some hacks to desactivate windows services and co because illuminatis. (And all dead HDD because moving/hitting PC and cie…).

Testing the backup images is vital to avoid surprises but anyway if you trust your method it’s all on you.
I didn’t say that backups are useless, anyway I will add to my previous post that saving every bit changed on your computer is time/space consuming for very little benefits. Yeah maybe it will save you 2-3 times, but maybe restoration points will do the same without stressing about it ?

My important files are already “backuped” by myself and by cloud, I don’t need to backup my entire PC for every action I make on it, and if there is a problem, one restoration point may correct it. In fact since XP I didn’t had to reinstall my windows on each PC I got, maybe because I didn’t do “bad things” (to be polite) on them, even worse (lel) I let windows update all these years :grimacing:

So my complete sentence is :
There are problems that impact every user, there are others that impact some users. Like… Cyberpunk

Sadly for me on my PC Cyberpunk is running better than AOE2 DE, a game I play since 1999 (it was not DE, no typo here plz plz) :crazy_face: Okay it’s 20-30fps but hey. And oh boy, how did my PC to never crash in 70hrs of CP2077, no sensible or fustrated blocking bugs that a lot of guys get and others don’t ?? When I watch youtube and co and see all those bugs… I’m lucky… except with AOE2 today.

Also, AOE3 DE runs fines too… :man_shrugging:

I hope I didn’t make too many language mistakes. Have a good day.

worry not, I am not one of those who argue to win and discredit everything about a person and all of their past statement if they were to make typo, which is why I asked if it was a typo. now if you were to go back on your own words and make stuff up along the way, I’d 100% point it out immediately to show the inconsistency.

since thats not what I said at all, I will leave that behind and you can read the above posts to see what I said was common sense, or maybe you assume that I imply common sense?

this is where common sense would apply, but you dont see it as common sense, maybe it isn’t so common? Cyberpunk should play better on your PC than AOE2DE simply for the fact that it is a game to take advantage of the newer hardware. where as AOE2DE still runs on the same engine as AOE2 (majority of it anyway) and it is written to run off only 1-2 cores at best. it would make no sense for AOE2 to run better than cyberpunk unless your computer hardware is real old.

no point of arguing these less relevant things just to prove right or wrong so back on topic. what does affect AOE2 performance would be hardware spec, more so on the CPU side, also the poopy microsoft server seems to affect online gaming performance for reasons other than network speed.

You got a point for the old AOE2 engine, of course even dual cores were not supported at the time (dual CPU with two PIII existed but it was a hack).

The thing that is interesting is that the game was working so great before this patch so I don’t know, I hope the next DLC comes with a patch that may correct some things and maybe my problem will be corrected. I did even more tests yesterday to find some reproduction steps for my bug, maybe more GPU related than CPU.

I apologize for being a bit rough but this is frustrating. I’m on HD to compensate but well I like the two and got a lot of games waiting for me in DE. :joy:

they will probably introduce more bugs along the way, and breaking mods too