Frame rate is capped at 60 FPS when V-Sync is disabled

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.58259.0 8059288
  • OPERATING SYSTEM: Windows 10 Pro 64-bit (10.0, Build 19043) (19041.vb_release.191206-1406)

:arrow_forward: ISSUE EXPERIENCED

When the V-sync option is disabled AOE2 DE is limited to 60 FPS. This behavior began after the Feb 1 update.

:arrow_forward: FREQUENCY OF ISSUE

  • 5/5

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Launch AOE2 DE on a machine that has a high refresh monitor.
  2. Enable an FPS counter. Open the Options menu and navigate to the Graphics tab.
  3. Disable the V-Sync toggle.
  4. Examine the current max frame rate.
  5. Enable the V-Sync toggle and verify that the max frame rate increases.

:arrow_forward: EXPECTED RESULT

AOE2 DE is capped at 60 FPS if the V-sync setting is disabled. When V-Sync is enabled, the max frame rate is capped at 144 FPS. Players who wish to play at higher frame rates will now be forced to use vertical sync.

:arrow_forward: IMAGE

:arrow_forward: ATTACHMENTS

DxDiag.txt (107.2 KB)


Hi @Amikar !

Thanks, we are now tracking this issue!

Have the same issue.

Before 8059288 i was only able to have uncapped fps with radeon enhanced sync enabled and vsync off.
On 8059288 with vsync ON my fps are capped to 70hz (windows setting for monitor)
On 8059288 with vsync OFF my fps are set to 60hz.

But 60hz doesnt exist on my system. So its either set by game client data, or the game reads out some default/fallback fps rate of 60hz from the os/driver, which is not used at all.

The Problem is that DE has really bad frame times occasionally, and it’s better to have the fps uncapped or capped to 150hz, if not a >=120hz screen is used.

I have the same issue. I have a 144 Hz monitor but game caps at 60 FPS with V-sync disabled.