Framerate Limit higher by about 10% in-game

The setting does not seem to work accurately even after switching to ‘Exclusive fullscreen’.

The 120fps setting limits actual in-game fps to 134 and putting it on 75 shows a steady 80 in-game fps.

There seems to be a 10% difference, not a huge deal but I wanted to play at 120 to reduce CPU/GPU load as it’s not an FPS.

One workaround is to set the Max Framerate in NVIDIA control panel which actually sets it to the correct value.

1 Like

what is your gpu???

GPU: 1080ti
CPU: i7 4790K OC’d to 4.6 Ghz
RAM: 16GB 2166MHz

Hey there, thanks for the report. Will pass along to the team.


can you add more options after 75 instead of jumping to 120?

1 Like