Game breaking softlock for unknown reason

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: latest to current date

:arrow_forward: ISSUE EXPERIENCED

Game soflocks in multiplayer after unknown event. The game continues to run, but as player I was unable to control it, basically like all keys and mouse were disabled. Only key that worked was alt+f4, so I was forced to leave and ruin multiplayer game.

A lead: before that happened, I had chat window opened and maybe by accident clicked to text area. Not sure. When I closed chat window, soft lock happened. Not sure why would that happen.
I heard similar thing happened to more people.

:arrow_forward: FREQUENCY OF ISSUE


:arrow_forward: REPRODUCTION STEPS


:arrow_forward: EXPECTED RESULT

Do not soft lock and break the game when doing anything.


Here is a short video. You can see, that by combination of chat window hotkey (F7) and Escape it gets to softlock. It appears as paused, but does not react to unpause (F3) nor any other key or mouse clicks.

Something similar happens in multiplayer too, only in MP there is not the pause oveerlay.


I found one way to safely soft lock the game:

  1. Repeatedly press hotkey for chat window.
  2. Close the window.
  3. Repeatedly press hotkey for chat window.
  4. Close with escape
  5. Game went to paused even without pressing pause hotkey. After that, no other hotkey worked than alt+f4.

Not sure if the chat window hotkey has to be pressed repeatedly, but this way it broke game 100%.

Someone probably missed some enable_keys_again function 11

1 Like

Experienced the same problem multiple times. Luckily it was during a MP scenario, and not ranked.

HI @Leondengrance !

Thanks, we are already tracking this issue!

Game does that specifically when opening chat for me, possibly after my team mate contacts me (via ping or chat). I couldn’t repeat the problem in a single player game, but ranked or unranked MP matches it locks up.

No pause game overlay either and I can only alt-f4 out of the game


I am also experiencing the same issue on Windows 11. Additional info I’m recently seen:

If I wait for the game to end the game unfreezes and you can continue.


Have noticed this occurring in several games with high repeatability, both multiplayer and singleplayer:

Opened chat window with button in top right, typed 104 to enemy, switched back to allied chat, closed window. Upon opening next time a few minutes later, reliably, game forces Pause with no way to unfreeze.

Repeatedly opening chat window and closing it eventually forces the issue as well. Alt+F4 is only way to break out.

After pressing Alt+F4, game seems to unfreeze to allow me to select yes when asked if I want to exit game. Pressing Yes exits the game, but pressing No returns to the softlocked state,