Game broken since Indian Dynasties

I bought the Indian Dynasties DLC and liked it a lot. Thing is, 90% of my game experience happens around mods, as more often I play with my friends who prefer to play with custom civ mods and custom maps, and I never play without small trees or idle villager pointer. Problem is that since I bought the DLC my mods have been totally broken. None of them work, they look like eternally loading/downloading in both Installed Mods and Browse Mods tabs (as seen in screenshot 1), I cant suscribe nor unsuscribe to them. I even tried deleting the files in the mod folder but when I open the game again they are already there doing as if they were downloading, but they never end (or start?) any download. For my friends who haven’t bought the DLC they work totally fine.
I feel scammed, like if I had payed to downgrade my game, now I can’t play the things I most enjoyed of this game. There’s been a lot of time since this issue started, and I had already reported it in the mod section, but nothing has been done. As this problem doesn’t seems to be ending anytime soon, I’d like to know if there’s a chance to return my game to the previous version (my version is on screenshot 3), so I can play the game the way I liked it and then get the DLC again when this issue has been fixed. I really liked the DLC but nothing beats playing with my friends the way we want to play, also I can’t stand the normal sized trees anymore, I can’t even find my lumbercamps behind them.
Hoping for a real answer this time.

A lifetime yet a little dissapointed player.


HI @CapitanPetit !

We are aware of this issue, thanks for your report anyway!

Thanks for the reply
You are aware but, is it being adressed? And if so, will it be too long? Because has I said I’m willing to go back to my previous version of the game if this will take too long, I miss playing the game the way I intented to play it when I first bought it…

1 Like

Unfortunately we cannot provide an ETA, but yes, it is being tracked internally.


I know a few palyers who we play on a consistent basis running into this issue. vast majority of them are outside of north america which makes us suspect its the download speed being extremely slow, or perhaps limited or even blocked to some extent.

where are you located?

most that I have seen, north american players would not little issue downloading mod as long as they have decent internet speed. however players from China, Japan, Korea and Australia seems to have issue.

two players that I know of have great internet speed of 200mbps+, but when downloading mod from in game they get a speed of measly 70-100KB/s. I honestly think this is an issue that needs to be addressed.

Im from Chile and have no internet problems at all. I have optical fiber (I don’t know if that’s how you call it, I’m doing a direct translation, but it means I have very fast internet) and other online games don’t have any issues. And it’s not that, because it makes as if it was downloading, but after a while it just stops, and if you look at the files in the mod folders it’s all there, as if it was downloaded, but then you open the game again, and it’s like if the mods where never there, and it starts “downloading” again (even tho the files are there already) until it just stops and the mod is removed from the installed mods list as if it was never there. If I try again the same happens, and the mod is never made available. If the reason this is happening is the internet connection then it has something to do with the game, because it’s not my ISP nor my PC.
To the devs, I insist, if you guys can’t find a solution to this problem I want to return my indian dynasties and my money back until this is fixed, then I’ll buy the expansion again because it is very good (the best one until now, if not for these issues) but is not better than playing the game the way I want. I’ve lost a lot of game time due to this, and I’m kinda tired already, I want my game back, is this possible or not? Because it’s the third time I ask for this and I always get answers on other things, except this. If it’s not possible I’d like to know, so I stop asking and looking like a fool. If it’s possible I’d like my game back to the previous version as soon as possible, there are many things I’d like to try in-game that I haven’t been able because of this.

1 Like

Is it possible to have the previous game version back? Without Indian Dynasties? At least for the time you’re fixing this…

Hi @CapitanPetit
I copied the mods folders from the subscribed and pasted them into the local folder. It works. You are still unable to download any new mods, but you can have your old ones back. For new mods, you can just ask someone to send you the folders and you put them in local. Hope it helps!

Hi @CapitanPetit !

It is not possible to play in a older version of the game.

Not sure how can you ask for a refund, I recommend you to contact support:

If the problem is not solved, please contact support:

You can’t install any mod, or just some of them? Maybe ones that have special chinese characters?


It is I believe, though you probably cannot play ranked games with old version:

As I previously said, Im Chilean, not chineese, and has I also stated before none of my mods work, not a single one, not even official mods like small trees, which I really miss a lot, it’s so wierd to play without it once you get used to it. Also I don’t know about the game versions, I don’t know if the game version changes when you have a DLC or what is it that changes, but has I said, my friends that don’t have the DLC have no problems with their mods whatsoever, that’s why I think it’s because of the mod (also the problem started when I bought it), so I thought that by returning it the problem wight go away, which would be a shame because I like the DLC a lot, but I’d rather have my game back.

Many of us have the same problem but I found that work around that I previously explained. Just paste the mods folder in local and you can have your mods back

What if you disable the DLC? Does it work then? If so, you could keep the DLC and enable it if you want to play some DLC content.

On steam: go to game => properties => DLC => uncheck the DLC you want to disable

Tried both things (disabling DLC) and moving mods to local folder. Neither worked :frowning:
The DLC stays enebled dispite what I select on stream. And even tho now my mods appear to be there and don’t appear downloading, they don’t work at all.


I posted this for a user with a similar issue, and it partly solved his problem by being able to unsubscribe from mods.

Unfortunately the only thing that you might be able to do here that i can think of is trying to install the game on another pc/network and hope it installs there. then you can unsubscribe them. The issue of mods not downloading is a known issue and is being tracked.

If you are out of ideas, try contacting support: