Game Constantly Crashing

I downloaded Age of Empires 2: Definitive Edition yesterday and played for about 5 minutes testing some stuff out and it was working great. I then installed the DLC Enhanced Graphics Pack and turned that on and tried to play a campaign mission as a test and it crashed. I tried a few more times in the campaign after that but I was met with more and more crashes. I then looked up solutions to the problem, and then changed stuff that somebody told me to change updated stuff that needed to be updated and it still crashed. I then looked up NVidia drivers which I hadn’t done before and downloaded the newest version from what I could tell. It did a search for compatibility and said it was not compatible I then went to the intel drivers and found out I was up to date. I tried again a few times and it still crashed, here and there the game would run and would look beautiful for like 5 seconds and then I would press a button and the screen would freeze or crash. I then uninstalled and reinstalled the game and DLC and it still crashed after that. I’m not an IT specialist so I’m not super good with changing values and all that. I’m apparently not the only one with these problems as I’ve seen a lot of people on the discord support channel with many many different issues, but they are mostly saying that the servers aren’t working in multiplayer. I have an Ethernet and have a device that prevents the overheating of my computer so I have no idea.

3 posts were merged into an existing topic: [Crash] Game Crashes Every Time with Enhanced Graphics