Game crashes 5 seconds after clicking play

Game Version:

Can you check without being able to launch the game? I’m sure it’s updated to the latest on steam. have also tried older versions through the betas tab in steam and the outcome doesn’t change. Ever since the 2.7 update, this has happened to me every time I try to run the game, so whatever changed in the backend of the game is broken.

Issue:

Game crashes 5 seconds after clicking play game, just will not run at all, I can’t even get to the startup screens. Just get a black screen for 5 seconds then i see the desktop.

Reproduction Steps:

  1. Start game from Steam, with or without launcher
  2. Black screen…
  3. Steam says I’m no longer playing AoM Extended Edition and I get returned to the desktop

I have tried changing resolution and window modes from the configs since some people have tried it and fixed their game, I have tried uninstalling and reinstalling the game and still doesn’t even show me a loading screen. Other people have been having this issue for a while, surely something is in the works. You could at least tell us if anything is being done rather than leaving people in the dark…

I posted mostly the same topic just over 3 weeks ago with no response (in the same forum), if I have to, i’ll go through steam for a refund because the game is completely broken for me and many others it seems.

My pc is more than capable of running the game…

CPU: Intel Core i7 8700k
Motherboard: Asus Maximus XI Code
Memory: 32GB Corsair Vengeance RGB Pro
Video Card: Gigabyte RTX 2080 Ti Gaming OC
Displays: Acer X27, Asus PG278Q, Dell U2412
Storage: Crucial P1 1TB NVMe, Kingston HyperX 240GB, WD Raptor 600GB, WD Black 2TB
OS: Windows 10 Pro x64

2 Likes

I have the same problem since I installed it but if nobody wants to do something and everybody is ignoring us then I wont be able to play it in the next two years @ms_age_team

Hey, I have the exact same problem! Boot up the game, click play: Black screen–>game closes.
Two months later and no reply sucks, but this issue is even suckier- reproduction of the bug is nigh impossible for people who don’t have the problem! Would you have to post your game data to give any idea on what’s wrong?