Game crashes on loading

Game Version:

Age of Empires II DE - Steam


Game crashing on loading. Everything was normal until yesterday, now on ranked matches the game crashes on the loading screen, when the match has already been found. The information of the game (civs, maps, etc) do not appear on the black screen and the game crashes almost instantly.

When i happen to get to a game, the writings do not appear (no nicknames and no written text).

I already uninstalled and installed the game again. The issue continues.

Ty in advance.

1 Like

Having same issue , with rankend game. y try reinstalling but no luck. Also is a try to search a game on the lobby it dont find any game


Yeah, no games appearing on the lobby or spectate game. Standart games (against pc and campaings) are working just fine.

It must have something to do with the new actualization, since I have 300+ games played and was working fine yesterday. So, any ideas?

The strange thing is that for me it stop working since Tuesday. Yesterday i help my brother setup a bootcamp and he was able to play without any issue.

I have the the steam version no mod only the hd pack. I try reinstalling the game but no luck. The last thing i did before playing that last game was getting the 21 century challenge. Am not sure if that cause a bug

This is an old problem. But a user just said that login of xbox life from the game solve the problem, i will try later today

Well, I have no idea how, but somehow its working now. I was going to login on xbox live, but I was already logged. So I tought I might re-log. That didnt work, its not logging on xbox anymore. So I went and changed my icon, I checked crossplay again on the options menu, and everything was back to normal, altough is not logging on xbox-live.

Hope it helps you someway, no idea whats happening, but I can play again.

Good, once i get home i will check to see if that help me too thank you

It worked to me, just needed to logout from xbox live and now it doesn’t crash anymore. It was almost unplayable before. Thanks a lot.

Same issue here, here are some logs if needed (signing off from xbox live helped)
2020.03.08-16.03.13.txt (6.1 KB) 2020.03.08-17.03.10.txt (6.1 KB) 2020.03.08-17.09.33.txt (6.1 KB)

For those of you who were able to sign out of Xbox Live to solve the issue: would anyone mind capturing a video of the issue when it happens? As we are unable to reproduce this issue internally, seeing exactly what happens before, while, and after logging in to Xbox Live (and then how that changes when you log out) will help our team see what’s happening from your perspective.

Thanks for the help!

I can do it later. But could you give me an email, or some other private channel? I don’t feel comfortable to share a video with my data on a public forum.

Feel free to PM me with a video or link! =)

Not sure if this is the same issue but when I try to launch the game I see the splash screen and it might start to look like the game is loading and then the screen flashes and the game never loads. I have tried reinstalling but no dice. I also tried signing out of Xbox Live but that did not help either. I have not gotten to play the game at all since I bought it.