Game Crashes; Unknow reason

Game Version: 101.101.35584.0

  • Build 4714640
  • Platform Steam


  • Frame Drops since the last patch.
  • Game Crashes for unknow reason but same error message, the last 10 times i tried to play.
  • I reinstalled Nvidia Drivers, Intel drivers and did Windos 10 update, problem still exists.
  • I reinstalled Age of Empires 2 Definitive edition three times, nothing changes.

Reproduction Steps:

  1. Just Load any saved game or start a new one (the last 4 times happend on a saved game of Honfoglalás Campaing).
  2. Starts with no problem until i give a random action to a group of military units.
  3. The units may be attacking or just moving and game crashes.

Error Message:

  1. If i wait 20-30 seconds, i get a windows blue screen od death with VIDEO_TDR_FAILURE error on nvlddmkm.sys every single time.
  2. If i quickly close it when crash starts and before bsd, i get the following message:
    c:\programfiles (x86)\windows kits…\direct…rix.inl
    line 2592
    Expression: !XMScalarNearEqual(ViewWidth, 0.0f, 0.00001f)
    assertion failure

Before the last patch, i didn’t have any problem at all!

Can’t attach a screen shot but will provide video evidence if problem isn’t clear.

1 Like

Do you also play Tom Clancy and use a certain cheat engine?

Because your error seems to be related to malware.

First of all, thank you for the answer.
Second, no i dont have Tom clancy game and i dont have cheat engine or anything related to it.

I don’t see how this could be a malware. This is the message i get last time.


1 Like

Hey there! I’ll echo what I mentioned in another recent thread to see whether it helps with your issue:

Please keep me informed! =)

1 Like

You are welcome here. Some quick search showed up a few possibilities, also running on Windows 7 was listed among the results. Also this seems to be related specifically to the Steam version, more reports about this one coming in. Just follow the steps @GMEvangelos supplied.


Hi, sorry for the late answer, i have been reinstalling stuff and it took me a while.

I had already installed Visual C++, so i repaired it, reboot and update Windows 10, also reinstalled AoE2 DE. Problem still persist.

I also did a malware analysis, just in case, and no problems found.

i really dont know what else to do, one month ago everything worked fine :sob:

I will leave my computer specs:

OS: Windows 10 64-bits
RAM: 16 GB
Processor: Intel i7 - 4700MQ

It looks like you are using a laptop to play the game? Can you verify that the game is running on your dedicated graphics card rather than the integrated chip?

  1. Right click on your desktop and select NVIDIA Control Panel.
  2. Click on Manage 3D Settings.
  3. Open the drop down menu for Global Settings. Select the High-performance NVIDIA processor as your preferred graphics processor and click Apply.

Then try launching the game again and let me know if you’re still encountering any issues.