Game Crashes when loading a saved campaign game

Game Version:

  • Build: 101.101.36906.0 4941835
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Morigandois


I have already played for a while, i haven’t played multiplayer yet as I’m focused on the campaigns. I don’t have many hours played because I only play at weekends.
After downloading the last patch I wanted to continue a campaign scenario I had saved from the previous patch, it was Genghis Khan 3: Into China. When selecting the saved game it shows the loading screen for a second or two and then crashes, the game shuts down and I have to open it again.
I verified files, checked if I had the minimum requirements (I do, as the game was working before), disabled mods (which had been working with no problems before), moved the game from a drive to another (the original one was actually close to be filled, and the new one had a lot of space so it made sense that that may have been the problem), the antivirus is not preventing me to play as I can start new games with no problem, also tried to start the game directly but it showed that I wasn’t starting it from steam so it automatically started it from steam, nothing worked.
Then I created a standard game, saved it and then went to the home screen and continued it from saved. It worked perfectly, so I tried to start the other games from this standard game and instead of crashing it sent me to a “home screen background” with a note saying ‘Failed to load game’. After that, trying to load the saved campaign game sent me to that message instead of shutting down the game. Exiting and entering Aoe again reproduced the problem as initially.

Ps: The standard game I made was randomized and it was a ‘wonder race’ that had Castle age as max age… was like playing a standard 1v1, locked teams, and the other player being an ally… (It’s not a problem, just an inconsistency that might be fixed)