Game Crashes When Loading

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 7694700
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Whenever I want to start a game (Single/multi), it crashes to desktop without notice.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Launch the game
  2. Select any game mode
  3. Game crashed on the logo, during the transition screen

:arrow_forward: EXPECTED RESULT

I should be in the game, not crashed to the desktop

:arrow_forward: LOG FILES

See the file below, it contains everything, DxDiag included.

Upping the topic, if anyone got a clue it would be much appreciated.

Thanks :slight_smile:

Hi @Alapaches !

Can you try to verify your files in Steam? Game, properties, local files

Also could you disable your mods?


Hi there !

Thanks for the answer !

I already did that but to no avail. It seems to happen whenever the game is loading.

The videos runs just fine but when any sort of game loads, I get a crash to the Desktop whitout any error message.

The game runs just fine on all of my other computers.

Can any update may have brought end support for specific graphic cards ?

I do not remember any change related with that, it should be something else umm

I recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.
b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.
c. Copy your user folder to a safe place, it has lots of numbers.
d. Delete the original folder
e. Verify your files in Steam, AoE2 game, Properties, Local Files.
f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

If this does not work you can also try:

  1. Reinstall the game
  2. Uninstall/unable your antivirus or add the game to exceptions list
  3. Reinstall your graphic drivers, update Windows
  4. Update direct X
  5. Make sure that your game is not running on the integrated GPU
  6. Uninstall Citrix (if you have it)
  7. Restart your PC and close as many background programs as you can before starting the game.
  8. Disable Enhanced Graphics if your hardware is not very fast
  9. Installing latest VC++ redistributables from here (both x86 and x64 variants): Latest supported Visual C++ Redistributable downloads | Microsoft Docs

Let me know if it works!

Man it worked !

I don’t know why. I tried everything and it kept failing. But this time, when I reinstalled the game and restarted the PC just right after, it worked for the first time in like, 8 months !

Thank you so much !

1 Like