Game crashes whenever a game starts

I can load the main menu but as soon as I load into a game the application crashes.

The logs show the following:
“”"
LocalizationManager::LocalizationManager end
Player sign-in processing complete
[rlink - error] 2023/10/12 19:23:44.063 (UTC) XBoxAchievementService::HandleGetRelationships, response error: invalid_argument
[rlink - error] 2023/10/12 19:23:45.778 (UTC) presence data missing
[rlink - error] 2023/10/12 19:23:51.810 (UTC) presence data missing
Closing video
[rlink - error] 2023/10/12 19:25:30.560 (UTC) user clean up called
[rlink - error] 2023/10/12 19:25:32.383 (UTC) XboxPlatform::SetPresence not successful: XboxLiveContext is null
[rlink - error] 2023/10/12 19:25:32.945 (UTC) presence data missing
UnhandledExceptionResponse_BugSplat
UnhandledExceptionResponse_BugSplat: IsSuspendingOrResuming() = false
UnhandledExceptionResponse_BugSplat: DisconnectRelicLink()
UnhandledExceptionResponse_BugSplat: WriteCrashAutoSave()
“”"
It seems to refer to a problem with XboxLive? I tried logging out of Xbox (I use the steam version) and had the same problem.

I would upload the full logs but “New users cannot upload files”

Does anyone know how to resolve this issue?

edit:
A new log shows a slightly different error still regarding the connection to XBox account it seems :
“”"
LocalizationManager::LocalizationManager end
Player sign-in processing complete
[rlink - error] 2023/10/12 19:37:08.681 (UTC) XBoxAchievementService::HandleGetRelationships, response error: invalid_argument

[rlink - error] 2023/10/12 19:37:10.783 (UTC) presence data missing

Closing video
[rlink - error] 2023/10/12 19:37:16.845 (UTC) presence data missing
“”"

Found this post searching for the same exact error message.

Copying my log since the previos part is a bit different:

Setting up hotkeys
LocalizationManager::GetOSLanguage: userPrimary is it
LocalizationManager::GetOSLanguage: Located user primary.
LocalizationManager::GetOSLanguage: Located user sub, returning 6
LocalizationManager::UpdateSelectedLanguageFromOptions
LocalizationManager::GetOSLanguage: userPrimary is it
LocalizationManager::GetOSLanguage: Located user primary.
LocalizationManager::GetOSLanguage: Located user sub, returning 6
LocalizationManager::UpdateSelectedLanguageFromOptions: Calling SetCurrentLanguage(6)
LocalizationManager::LocalizationManager end
Player sign-in processing complete
[rlink - error] 2023/10/15 14:50:49.409 (UTC) Error from Xbox live social event 0x83750007 from condition 1
[rlink - error] 2023/10/15 14:50:54.437 (UTC) presence data missing
[rlink - error] 2023/10/15 14:51:14.477 (UTC) presence data missing
[rlink - error] 2023/10/15 14:51:14.516 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:16.655 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:47.908 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:49.654 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:49.774 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:50.407 (UTC) Rejecting packet type 0 that claims to come from ourself
[rlink - error] 2023/10/15 14:51:52.350 (UTC) Enum changed on the server AdvertisementUpdateTagsEvent::Result
[rlink - error] 2023/10/15 14:51:53.336 (UTC) presence data missing
[rlink - error] 2023/10/15 14:51:57.370 (UTC) Enum changed on the server AdvertisementUpdateTagsEvent::Result
SyncMandatory is being logged
[rlink - error] 2023/10/15 14:52:52.935 (UTC) Enum changed on the server AdvertisementUpdateTagsEvent::Result
[rlink - error] 2023/10/15 14:52:54.541 (UTC) Rejected PlayerReadyRequest, state is not MS_Setup
[rlink - error] 2023/10/15 14:52:54.857 (UTC) Rejected PlayerReadyRequest, state is not MS_Setup
SyncMandatory is being logged
[rlink - error] 2023/10/15 14:53:28.936 (UTC) Achivement failed to update
[rlink - error] 2023/10/15 14:54:03.102 (UTC) Achivement failed to update
[rlink - error] 2023/10/15 14:54:22.255 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:54:47.299 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:55:07.338 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:55:12.339 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:55:22.364 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:55:52.410 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:56:27.451 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:56:32.448 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:56:37.468 (UTC) Achivement not modified
[rlink - error] 2023/10/15 14:56:52.541 (UTC) Achivement not modified
UnhandledExceptionResponse_BugSplat
UnhandledExceptionResponse_BugSplat: IsSuspendingOrResuming() = false
UnhandledExceptionResponse_BugSplat: DisconnectRelicLink()
UnhandledExceptionResponse_BugSplat: WriteCrashAutoSave()
WriteCrashAutoSave: Generating autosave...
[rlink - error] 2023/10/15 14:56:52.851 (UTC) SetVisible called while !IsConnected
[rlink - error] 2023/10/15 14:56:52.851 (UTC) SetVisible called while !IsConnected
Writing crash record file.
Done writing crash report file.
Attaching crash record file to Bugsplat.
UnhandledExceptionResponse_BugSplat: bugsplat_wrapper_dll::GenerateDump()
UnhandledExceptionResponse_BugSplat: bugsplat_wrapper_dll::ExceptionFilter()

It’s been months, I’ve tried reinstalling, logging in/out with Microsoft account, removing mods and profile data, changing accounts…

Here’s the full log:
2023.10.15-16.49.28.txt (35.1 KB)

In case it helps someone else. This is what I did to be able to play on steam again. Not all steps might be necessary.

  1. Log out from xbox account

  2. Disable all mods

  3. Uninstall the game

  4. Remove all aoe2 related files (create a backup first)
    4.1 C:\Program Files (x86)\Steam\steamapps\common
    4.2. Using your keyboard, click Windows button + R and type in: %userprofile%\Games. Delete the folder “Age of Empires 2 DE.”

  5. Update to windows 11 (Probably not necessary)

  6. Reinstall the game

  7. Create a new xbox account and log in with that (Probably not necessary)

If you have other problems this aoenote might help: Crash to Desktop Fix for Age of Empires 2 Definitive Edition