Game crashing on start up

  • Build (Not sure how to get build on steam sorry)
  • Platform (Steam)

Hi guys, really hoping you are able to help me out here, ive been scouring the internet for a while with no actual resolution… Firstly I will copy and paste a description of the exact issue I am having, as this person worded it better than i could

***What i tried:

  • Uninstall & Reinstall
  • Uninstall older C++ redist…
  • Installing newest C++ redist and try to start the game
  • Installing newest C++ both x64 and x86 and try to start the game
  • Installing older C++ redist and try to start the game

Updated all drivers, closed some background processes… No extra antivir installed (using win defender) - checked firewall options…

still can not start this game… What exactly happens ?

Starting via Steam with skiptintro:
Bootload-Image appears and disappears after 2-3 seconds. That’s it.

Starting via exe:
Bootload-Image appears, error message “SteamAPI_RestartAppIfNecessary() has been triggered. Aborting startup” shows up. then nothing else happens***

(Link of forum for reference - - note scroll down to TALHAs post as thats, from there going down isall that was said on the issue, unfortunately the thread was closed as resolved with no actual resolution.

I have noticed there are a few other posts similar to this however again do not seem to have a resolution, or at least ones that I can see. If anyone could point me in the right direction I would be really appreciative, my cravings for AOE are killing me at the moment.

Let me know if you need to know anything else, I will try to get the info to you as soon as possihble

Hi, have you tried logging out from Steam and then logging back in?

Yes I have tried logging in and out.

Every basic fix to the issue I have tried. Reinstalling all related apps, moving the program files from one drive to another, restarting computer, etc.

Hmm, that’s strange. Probably not related, but check your page file size is set to system managed. Also check the Windows event viewer to see, if there are any error logs, especially when you have the skipintro command set.

Just bumping this as a resolution has still not been found, I was hoping yesterdays update mightve fixed it (I also tried un installing and reinstalling on another hard drive after the update came in) no luck still.

So desperate to play but this is killing it.

Symptoms still remain the same two months later - crash on start up, no logs to report as far as i can see, no error message, just get the small picture of the three kings before it goes back to the steam launcher.

Hi there @doobey123! Thank you for following up. It looks like you’ve already worked through many of these steps, but can you confirm a few things for me:

If you would attach a copy of your dxdiag and any error logs generated by the game or Windows as a result of the crash, it would be most helpful in trying to figure out your issue.

Thank you!

1 Like


Yes I can confirm all three above. The only thing that MIGHT not meet requirements is ram? I’ve heard DE2 takes up quite a lot of ram I have 16gb(paired with a ryzen 5 and a 2070) and don’t have trouble running any other games including DE1.

I have gone through all the trouble shooting without any luck either.

I will post a picture of the crash report once I get on the computer in the next half hour


Okay so I am not sure if this is anything to do with AOE2DE but its the only event I can find relatively close to the launch time

svchost (7656,R,98) TILEREPOSITORYS-1-5-18: Error -1023 (0xfffffc01) occurred while opening logfile C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\EDB.log.

I have also tried opening the game from the root file by double clickiing AoE2DE_s and I get this on start up and then I get a black screen for .5 secs then nothing.



have a problem with launching AoE2(DE) downloaded from Windows store. Getting error while
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff662bf20bf.
As I have tried everything I could find on the internet (Forum & elsewhere), is there any solution that could actually help?
Kindly thank you for answer.

If you start the game from Steam or exe with Steam running in background, this error message does not appear? What happens instead?
Also, please let us know what the last few lines in the log files in C:\User… are?

Error comes up using EXE but not when launching from steam, same symptoms whether steam is open or not.

I have managed to get it working since I have last been on the forum so all good,I’m not quite sure exactly what fixed it because I did a number of things at once(stupidly).

I reinstalled on a different drive
I turned off the intro videos
Disabled a few apps like lighting services(which often plays havoc with anti cheat services)
I also tried a few other things I cannot recall.

If I can I will post them up here for the dev team but yay I get to play now!

Thanks for everyone’s help responding to the thread I really do appreciate it. I cannot begin to express my excitement to knock out some games!

Thanks again all!