Game does not launch

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 11771158
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

:point_down: Game does not launch at all. Launching the game from Steam or double-clicking the A0E2DE_s.exe file from \Program Files (x86)\Steam\steamapps\common\AoE2DE seems to do something for a couple of seconds but then goes away. I have tried adding the entire AoE2DE directory to Norton Antivirus exception list. My event viewer shows a number of entries like the following:

Failed to add certificate to Third-Party Root Certification Authorities store with error: Access is denied.

No more details are given about which cert(s) it is referring to.

I have tried reinstalling the game, reinstalling Steam, checking game files integrity, launching Steam as administrator - nothing works.

Game log (\Users<username>\Games\Age of Empires 2 DE\logs) shows:

Initializing Time System
Initializing Command Line
Problem with installation detected.
Exiting with code 0

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Launch the game directly or from Steam.
  2. Nothing happens
  3. Event Viewer shows above error.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Game should launch

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Just to clarify - this only happens for AoE2DE. Other Steam games work fine.

A couple of times today the game hasn’t launched for me. I had to shut down my computer and restart. The computer couldn’t shut down the game.

Do you have a Windows PC? I ran a sfc scan as a site administrator and it fixed some files. Now the game runs. Google what I have written and it should get you to it.

…Take back. It ran once, but now isn’t running again.

I can reliably reproduce the same issue on Linux. Previous game versions did launch properly but a recent update now produces the same log lines as described in the initial post.

Distro: Ubuntu 22.04
Tested compat layers: GE-Proton7-49, Proton 8.0-3, Proton 7.0-6
Steam version: 1690583737

I created a new WINEPREFIX after each switch but ended up with the same error. The last known good game version based on old log files is from 2023-06-02. Information based on the following log file:

Initializing Time System
Initializing Command Line
Constant Logging is OFF
Verbose Logging is OFF
Startup is being logged
Age of Empires II DE start at 2023-06-10T17:18:46.874Z
Build version: 101.102.20078.0 #(85614)
Build stream: phoenix_stream_release
Build config: Final Steam D3D11, built on MEL2-PWSBD-03, at 2023-06-02T12:04:26
DirectX is being logged
Initializing File System
( .. more ... )

There is also no error shown in the Proton logs (PROTON_LOG=1):

I also opened winecfg to use the drive letter D:\ for the game in hopes to circumvent issues caused by spaces in the path - no change. Checked the file integrity of AoE 2, Proton and the Steam Runtime - no change.

Several other players likely face the same issue:

Please have a look at this issue. It is a blocker.

Apparently this issue has already been reported earlier here: Game not starting at all (latest update) - #6 by TheTugaTog

For Linux in specific, the newest Proton Experimental does indeed fix the issue on my end.
Reddit info: https:// www.reddit. com/r/aoe2/comments/14mwbz2/aoe2de_playable_again_on_linux_via_steamproton/
Issue tracker: Age of Empires II: Definitive Edition (813780) · Issue #3189 · ValveSoftware/Proton · GitHub

Sorry for the link breakage. New users may only have 2 per post for whatever reason.

Thanks badgerfarm and KnutRick. I am on Windows so the Proton fix unfortunately won’t work for me. I also tried the sfc scan but no luck launching the game thereafter. I have another laptop on Windows 10 where the game works fine so there has to be a Windows 11 component to the cause of this issue too.

Hey Guys,
Yeah, the game still doesn’t work for me, even after reinstalling both game and steam and even trying several workarounds suggested by a dev.
I’ve given up, since I’ve now gotten me a second laptop (also windows 11, like my previous one), and it works fine there. Go figure…
Good luck with getting this fixed!