Game doesn't default to use GPU with NVIDIA video card

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 63727
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


When not configured otherwise manually, the game runs on integrated (CPU) graphics by default rather than the GPU. This is with GeForce 1050 Ti, driver version 511.79 (latest available at the time of writing) and GeForce Experience up to date.
Frame rates are low accordingly, about 20-30 fps for me most of the time and dropping lower when a lot is going on.
I wonder if this may be the cause of ongoing performance issues experienced by other people.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Right-click the NVIDIA settings icon in the system tray, select NVIDIA Control Panel
  2. On the left side, select Manage 3D settings
  3. On the right side, select the Program Settings tab
  4. In the first dropdown on the tab, select Age of Empires III:Definitive Edition (aoe3de_s.exe)
  5. Check the second dropdown

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Selected value should be “Use global setting (Auto-select: High-performance NVIDIA processor)”.

Actual selected value is “Use global setting (Auto-select: Integrated)”, meaning auto-select defaults to use integrated graphics.
Manually switching to “High-performance NVIDIA processor” fixes the performance issue.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


I don’t know if this is related but ever since the games release GE Experience is not able to automatically optimize graphical settings despite it being listed. I could see how this might cause people to have performance issues as well? I don’t know if it’s just my PC or a more widespread thing, thought I’d mention it as well.

I haven’t suffered any performance issues because of this however so it’s not a big deal.