Game doesn't launch after Season 5 patch

  1. CPU usage at 100%

  2. A message pops about updating drivers and hardware meeting minimum requirements

Never had issues in the past (i have Windows 11)

You definitely changed something, devs…

1 Like

Hey @ElFabuloso. Could you please lease contact support with your DxDiag and warnings.log file? It would be much appreciated—thanks!

got same issue, what your gpu name ?

1 Like

My friends has the same problem too. He does have a quite old computer but it was running the game fine before the update.

He gest the exact same message and when the game opens, its very laggy for him.

Can we get an eta for a fix ? If you actually can fix it. Please communicate as soon as you can on this.

Thanks !


Hey I have the same problems here

The game worked just fine before the season 5 patch…

I have a bronze age graphics card which is defienetly the problem

Here are my specs and a screenshot of the error message

Processor: Intel core i7-4770 CPU @ 3.40GHz
Nvidia driver version: 474.30
Direct X Version: DirectX 12

I have also opened a ticket regarding this issue. Will keep you guys updated if there is any quick fixes

Please help!
I want to play so bad!!!


Sane here after installing the update: “failed to find supported hardware rendering device…”

Win11, Ryzen 7, 16 GB RAM, GeForce GT 710 ( latest drivers in general
AoE 7.0.5861.0

When starting despite of the warning RelicCardinal.exe settles at 85-95% cpu load. Intro requires about 5min to load. Mouse actions and key strokes are delayed up to 1 minute. Process has to be killed.

Uninstalled, rebooted, and installed the game gain, without effective changes.

From warnings.log:
(I) [21:07:07.287] [000001724]: -------- Display Adapter Driver Information --------
(I) [21:07:07.287] [000001724]: Vendor: Unknown (0x1414)
(I) [21:07:07.287] [000001724]: Installed Driver Version: Unknown Vendor ID (0)
(I) [21:07:07.287] [000001724]: Required Driver Version: Unknown (0)
(I) [21:07:07.287] [000001724]: ----------------------------------------------------
(I) [21:07:07.287] [000001724]: GPU Performance Class: Gen7 Only
(I) [21:07:07.302] [000010528]: Enumerating Graphics Adapters
(I) [21:07:07.333] [000010528]: Skipping adapter because it does not support Direct3D 12
(I) [21:07:07.333] [000010528]: Skipped adapter: NVIDIA GeForce GT 710 - VRAM dedicated: 2104688640; VRAM shared: 8538359808
(I) [21:07:07.335] [000010528]: Choosing first adapter
(I) [21:07:07.335] [000010528]: Adapter: Microsoft Basic Render Driver video dedicated: 0 shared: 8538359808 system dedicated: 0
(I) [21:07:07.335] [000010528]: Chosen adapter: Microsoft Basic Render Driver video dedicated: 0 shared: 8538359808 system dedicated: 0

(I) [21:07:09.717] [000003776]: D3DLOG Begin
(I) [21:07:09.717] [000003776]: D3DLOG End
(I) [21:07:09.718] [000003776]: Failed to SetFullscreenState. HRESULT = 0x887a0004 -
(I) [21:07:09.718] [000003776]: RENDERING - Finished compositor fullscreen transition [1]
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_NOSIGNAL error=48
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_DNS_CACHE_TIMEOUT error=48
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_MAXAGE_CONN error=48
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_SSLCERTTYPE error=48
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_SSL_CTX_FUNCTION error=4
(E) [21:07:09.817] [000006496]: curl_easy_setop failed; option=CURLOPT_SSL_CTX_DATA error=4

The system configuration hasn’t changed over night, so the update of today which is skipping a previously working graphic configuration is a rather unusual experience.

1 Like

same issue
main problem with this update seems to be that older gpu’s dont support Direct3D 12
@SavageEmpire566 perhaps this info might help


Let’s pray the developers find a solution

1 Like

found this in:

still weird it worked before and now it doesnt
i wonder if the management will pull the plug on us because of the engine upgrade…

1 Like

I am running DirectX version 12 but my feature levels start with 11 - i hope they don’t drop us…

Screenshot 2023-06-17 023117

Screenshot 2023-06-17 023148

1 Like

the first is not the correct number
featured levels is the real one
and let hope they dont