Game drops fps with new graphics card (AMD RX 6600)

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.54684.0 7486483
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The game drops fps constantly and eventually drops down to 1 and basically stays there. In a deathmatch game the issue is constant after 30 seconds of playing the game and its unplayable. There are specific actions that cause the fps drops, like moving the camera or placing farms, yet eventually even without those actions the fps stays at the bottom.

I had an AMD 2400G and the game used to run perfectly, since I installed the RX 6600, the game has become unplayable. I have am using the right card and connected the monitors properly (to the card and not the motherboard).

Things I have tried to fix the issue:

-Reinstall the game
-Disable all mods
-Change the game’s settings (vsync, antialiasing)
-Change the driver’s (AMD) settings (freesync, Radeon Enhanced Sync, Radeon Anti-Lag)

When I changed some of the driver’s settings I managed to fix it temporarily, after opening the game again it was the same as before.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start a game
  2. Place farms


  1. Start a deatmatch game with 7 bots
  2. Wait 1 min
  3. Try to play

:arrow_forward: EXPECTED RESULT

The game should run smoother (or the same) with a better graphics card, not worse.

:arrow_forward: IMAGE

I’ll just show the fps counter when placing farms, since its easier.
Start of game:
1 fps when placing farms


You are having driver timeouts, dropping to 0 mean the driver stopped working, a friend is having the same issues with the 6600xt, try updating to the latest driver version(the betas non the wqhl), another alternative is to stream it or have another game running that uses the gpu, cause the game doesn’t stress enough the gpu.

Hey @FuriousPampa ,
problems with AMD cards have already been reported and are tracked, thx for the report

1 Like

I tried using the last optional drivers released (Driver Version, 16/11/2021) and the problem persists.

Yeah ı have the same issue with 6600 xt and streaming the game stops fps freezing. I think its driver problem.

Can you get more details? So when you start streaming the game stops to stutter?
Is there an older version of radeon drivers that are without stutter? I tested all versions from the last months since december. No change - stutter - stutter - stutter… Benchmark score is over 1,1k all other games on my system run perfect.

When the game starts, it starts to drop immediately and before I open the game, I record the desktop so that there is no drop problem, I get a score of 1280.

If you read this and have any further troubleshooting ideas, maybe I have overlooked something? Please do comment below.

In short:

I have tested this with numerous 4v4 unranked games, 200 pop (and in local play vs AI in a 4v4 Amazon Tunnel game, 300 pop.) Online games especially start lagging after a short while. Game freezes for a second or few, then resumes. Sometimes it completely freezes and only the cursor is working. I can give commands and after like 30s the game might continue running with accelerated speed to catch. Then it might work fine for a while but then the lagging and freezings starts again. Other players are clearly not affected. Commands can be given to vills and units.

In local play vs AI the stutters seems like “normal” and it’s only small stutters which have been there before. But even that is near unplayable due to lag, but atleast I can normally issue commands etc without having to wait dozens of second and wait my game to catch up.

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD: App ID: 813780, Build ID: 7486483
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

This started happening after upgrading my pc. I updated my CPU, riser cable and updated my AMD drivers. I noticed the issue first on this game. I then tested other games (online and offline) and 3DMark tests, Heaven 4.0 but all of them worked completely fine. I also tested with my old riser cable and checked all my connections and cables, but everything was fine. Also the CPU is working fine in all other applications so I doubt there is an issue there. Antivirus is set to ignore AoE 2 DE. Tested with TPM on and off. Game has been reinstalled once and files verified via Steam. Disabling mods had no affect.

When I start an online 4v4 game via unranked lobbies everything works fine at first. Then as the game progresses, it’s starts showing signs of lag that only affects me, other players have never experienced the same when I asked them. At first it’s most noticable when placing farms and other buildings. Game might freeze for half a second, then continues to play. When then placing multiple farms it might freeze for a good 5s before catching back up in a fast forward speed. Then as the game progresses to late game, post imp the stutters get worse. Game might freeze for dozens of seconds at a time. At worst it has been some minutes. Cursor works fine. I can use my pc to do other things normally (watching streams, surfing websites, using other programs, etc.). Only AoE is affected. During the worst massively long lag spikes, Task Manager shows 0% network activity for AoE which is quite odd. But my internet is working fine during this and I might have a stream running on the background with no issues. Otherwise hardware usage is quite low as is expected as this game doesn’t need much to run.

At this point the game is in a state where I can’t really affect the game. I might be able to give general orders to my units and set rally points where to spam units. But during the worst lags I’m not sure if any commands go through.

The ingame Ranked Benchmark Test gave me about 1150 points. The test lagged quite badly though. Previously I have gotten over 1300 points with almost no lag.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

I think the previous description gives a good representation how this happens. And this issue doesn’t affect everyone so can’t give any more info on this.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Game lags and stutters so much, it’s unplayable.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

This clip is not from my game and I found it from someone who had reported a similar issue. But it perfectly illustrates the issue. The video shows the mild version of the issue for me. When it’s bad, it gets way worse than the footage shows.

Age of Empires II Definitive Edition 2021.07.27 - (

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

  • Here are logs from the game, using the logging function from Enhanced Logging Build. The first two files are from an unranked Black Forest 4v4 online game, 200 pop. The latest is from a local 4v4 Amazon Tunnel game against AI, 300 pop.

They are downloaded to Google Drive (read only mode):

Further possible troubleshooting ideas:

I have not tested with my old CPU as I sold it. I have not tried to reinstall Windows, but I’d rather not do it as I need my pc daily (also CPU updates don’t warrant an OS reinstall). And as I have not had any issues with any other programs, games, etc, it would seem that this is an issue with AoE not linking something in my working PC setup. Also my pc is more than capable of running this game. Specs below.

My system specs:
CPU: Intel Core i5 11400f
Motherboard: Asrock H570M-ITX/ac (latest 1.5 BIOS from AsRock)
RAM: 16GB (2x8GB), G.Skill Ripjaws V, F4-3200C16D-16GVKB (timings: 3200, 16-18-18-38)
GPU: AMD Powercolor Hellhound RX 6600XT
Storage: Samsung SSD 870 EVO (Read: 560MB/s ; Write: 530MB/s)
Case, PSU, CPU cooling: NZXT H1, 650W, 140mm AIO
Monitor: Asus PG279Q, 144Hz, 2560x1440

This really needs to get fixed, as this this makes the game completely unplayable for some people.

1 Like

I’m yet to try this on a multiplayer game myself but I disabled radeon’s software from making changes to the game. Namely I took off Radeon Anti-lag, Image Sharpening and turned on enhanced sync.
I have the same GPU as you and I’ll let you know shortly if this worked for me. In my initial single player vs AI (online skirmish) it resolved the issue.


Hi @VkTsU

We are aware that the game could be lagged for some players, specially in late game.

Probably you have the same issue. However just to be sure, I recommend you to try some stuff:

  1. Reinstall your graphic drivers
  2. Update direct X
  3. Delete your user files

For deleting your user files, you should:

  1. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE
  2. Copy your user folder to a safe place, it has lots of numbers.
  3. Delete the original and open the game again. A new user folder will be created

If this works, then copy back the files from your old user folder. Those files are in the folder C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

Let me know if it works!

Hi @IkoKnight8151

Thanks for the tips.

I tried these but this didn’t work. I reinstalled drivers using DDU. DirectX version was already 12. Also before doing this I played some campaigns and they had 0 performance issues. I player mission 1-4 of Montezuma campaign. But when playing those at mission 3 my hotkeys got bugged and now they can’t be changed from legacy keys to anything else using the presets. Also one of my campaign saves from early on fro mthe mission just got corrupted and caused my game to crash whenever I loaded it I also saw that this issue has already been reported to you.

I also have my Steam Cloud storage full. I have deleted everything in game and each delete changed the percentage a little but after deleting all, it still is stuck at 98,22% or was it 92,88% or something like that. I even tried the Steam Cloud save deletion method found in here: How To Delete All Steam Cloud Saves

No luck. Maybe this system is bugged for AoE and since I’ve deleted everything via AoE2 DE, I never got the conflict message that I was supposed to get where I should be able to force Steam to choose my local files over the cloud ones. I thought maybe something corrupted was saved in the cloud things but no luck there since I can’t even get that working somehow.

I just hope that all campaign progress is saved somehow saved on Steam Cloud separately and I don’t find all my gold medals gone after I some say reinstall this again.

So online games are laggy, big offline games are laggy and now my hot keys just completely randomly stopped working.

At this point I’ll just uninstall the game until these things get fixed. I will probably even reinstall my windows completely at some during the holidays since it’s good practice anyways and maybe try AoE again if these issues have gotten patches.

And I truly hope you find fixes for these numerous issues.

Same happens to me, the game starts lagging a lot when I play 4 vs 4 or big maps.

Yeah, I don’t see why drivers would be an issue when I play 50 other games without issues. It wouldn’t be my driver’s or direct X.
I’ll try reinstalling AOE2 again while deleting all the core files.
But given this seems to be a routine problem with many others using the 6000 series, I would love some recognition that there may be a blanket issue on your own end.

Some more info for devs @IkoKnight8151

Yeah I had tested previous drivers to test this. So it should not be driver issue.

I did do another test though as there was a new Intel driver update: Intel - SoftwareComponent - 2130.1.16.1

Before that I had uninstalled the game, including user files, everything in Steam directory and files in AppData folder. So I think I got everything the game installs on your pc.

I managed to then play one game (unranked lobby, BF 4v4) with almost no issue. Only in the end of game was there a little lag that was not just the “normal” late game lag due to other’s pc’s not being able to handle the game. Then a day later I played a second game (unranked lobby, BF 4v4) and the lag returned in a mild form during feudal and and in a major way after imp and game was again almost unplayable with several up to 20s lag spikes with the same symptoms as described before. The lag was clearly not due to other players’ pc’s lagging or something like that. It was purely in my end.

This is what I encountered after completely deleting the game. It goes away for a game, then comes back the next day. Turning off sync does not fix it.

There are already 2 other threads about this problem. It has something to do with the 6600 XT - AoE 2 has problem with this card right now.
Can you confirm that the lagg starts after players reach feudal age?
Happen for me after feudal age in teamgames.
Some months ago there was the same bug with stutter. Need to wait for fix until can’t play the game

This is ridiculous. We are talking about a game that’s more than 20 years old. It’s published by microsoft, the same company that created this freakin OS and they can’t seem to fix it.
I have a Ryzen 9 5900HX, 32Gb RAM, Radeon 6800HD, 1.5Tb SSD and this issue keeps appearing on EVERY multiplayer match in different levels of severity. I lost 3 matches in a roll today because of this horrible bug.

Sometimes I can’t even click or give orders, the game freezes completely for a few seconds and then it kinda runs fast to catch up with what happened while it was frozen. It sucks.

And it is revolting that they can’t fix it or don’t seem willing to do it. I’ve sent emails to their support, tried every fix there is on the forums but without any success. Their support basically told me “there’s nothing we can do, you have to wait for a fix” and it’s been 4 months now. This is VERY upsetting and disrespectful.

It is not a driver issue. I have plenty other games, including AOE4. I can run basically every other game on max here and find no performance issues. Every forum thread I read about this issue they always seem to suggest that there is an issue in the user’s end, not theirs, even though my laptop is brand new and I’ve even formatted it to no success. It’s unacceptable.

1 Like

Winter and Christmas without some rounds of AoE feel sad. I think they don’t care if we find something unacceptable. If you are not an rich investor your opinion has no worth. We just can wait and hope there is someone in the backround fixing it.
Because its not the first time this massiv lagg after feudal age appears but back then more people were affected.

Sounds like Microsoft is being typical. Can’t be bothered to do it especially on older games. I wish I could get refunds for the extra content I bought at this point.
If they would at least talk to us and provide some update on progress being made - this would be way less frustrating.

1 Like