Game is freezing and won't let me close the game while not being able to use other programs

You should add the howle folder of the game to the antivirus exception list in order to avoid this problem.

it seems like Mcaffee can only do files, not folders. I also can’t seem to find this Howle Folder.

Not knowing the howle folder. I may just have Mcafee ignore every file I choose in the directory.

@Felizon89 I think this might be more of a windows 11 issue. Since my desktop is on 22H2 and the Bug messes with the GPU whenever GPU Debugging is activated.

I decided to test out my previous PC I used to play AOE II DE on which is a windows 10 laptop. I let it run a skirmish and when that finished. The game didnt froze on me.

I hope the next AOE II DE update may find a fix to stop GPU Debugging in windows 11 22H2 from affecting the game.

I just hope it will be in time since I am working on a review for the entirety of AOE 2 like I did with the first game.

I meant to write the “whole” folder, sorry about that.

What do you mean by write the whole folder?

I mean add the whole folder of the game to the exception list of the antivirus.

I see, I mentioned that Mcaffee won’t give me the option to add a folder as an exception. Instead, I have to add individual files as an exception. Which is pretty tedius since I let mecaffee scan the folder and theres 1000+ files.

Would uninstalling the Antivirus software work as well or not really?

@Felizon89 uninstalling Mcafee didn’t help either. Age of Empires II DE is still freezing.

Ive recently downgraded my PC to windows 10. Going to see what I have been experincing was actually a bug in Windows 11 and not just the game itself.

Downgrading to Windows 10 fixed the issue

heard other people were experiencing the same freezing issues on the steam forums. They told me Windows 11 23H2 fixed it. Upgraded back to 11 since I was on 22H2 before. The game isn’t freezing on my end.