Game is freezing and won't let me close the game while not being able to use other programs

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.30274.0 (#95810)12466982
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

When I save a campaign game and then go to quit the chapter of that campaign. I go to return to the campaign menu. When I am in the menu, it won’t let me click on anything like getting out of the game. I can press the windows key or ctrl+shift+tab to switch from the game window to steam to press the stop button from there but even that side won’t work like the game and everything except the mouse was frozen. I could only close down the game by turning off my PC the incorrect way by using the power button. That did work and when I went back on to see if my save file was corrupted. It wasn’t but I did run into the issue again when I quit and went back to the campaign menu.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Pick a campaign to play. I don’t know if it happens on any campaign since I was playing on Sargon of Akkad
  2. Load a chapter, save the game and then quit the game
  3. Go back to the campaign menu and see if you can click to go back to the main menu screen or if you can click on the stop button for steam

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game wouldn’t freeze and I would be able to quit out of the game and turn off my PC correctly

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

forum is not wanting me to post the youtube link
using the reply worked

I have a reason to believe the same file was corrupted. I reinstalled the game thinking it resolved which it looked like it did but the problem still occurred. Since it was the same save being backed up from Steam. I think it might have been corrupted. I should have included it in the beginning of this forum post but I guess I was thinking it was a bug.

Doesn’t seem to be a file corruption since the problem still persists.

Hi @Penteract4894
I’ve been trying to reproduce this issue, but I can’t. I recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.

b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.

c. Copy your user folder to a safe place, it has lots of numbers.

d. Delete the original folder

e. Verify your files in Steam, AoE2 game, Properties, Local Files.

f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

Alright, i did all the listed steps you wanted me to do. I put the numbers folder in a safe place while deleting it in the current folder directory. The problem still persists. Should I link the user folder?

Ive realized something, I only started experincing this issue when I downloaded the Mountain Royals Expansion. I am going to check to see what happens if the its uninstalled when i get back to my PC.

Uninstalled the game and made it so Mountain Royals won’t download when the game is finished installing. The problem still persisted. I may just wait for an update or 2 to see if it somehow gets resolved. Should I send over that folder with the numbers on it in here?

One thing I have noticed since I have 2 screens is that my cursor will appear on my other screen when i move the map to the right. But the thing that is odd is that the graphics settings is set to full screen and not borderless full screen.

You don’t need to send that folder :slight_smile:
If you go to Options - Interface - you can enable “Clamp Mouse to Window” so the cursor will always stay on the screen.
Do you have different resolutions on your screens?

I will try that, hopefully before it freezes on me.

No, both monitors are the same (1920x1080)

I think the clamp to the mouse solved the issue. I even pressed the windows key to see if the game would freeze and it didn’t. I did upgrade my graphics driver which might have helped.

I did unsubscribe all the mods and was surprised that my PC wasn’t frozen.

Also, i did disable to clamp mouse to window to see if the bug was caused that way and it didn’t. Might have been graphics driver version this whole time.

I guess its a mirical.

I will post something back in this thread if the problem comes back
But other than that, thanks for the help!

When I thought the problem was over. An hour later and looking at the score board. The game is frozen. Although the weird thing is that its playing the main menu music in the scoreboard menu.

Did it freeze without mods?

Yes, I unsubscribed all the mods to see if that could solve the issue but it didn’t.

I did some research lately today and realized what I am encountering may not be a bug and why you couldn’t replicate it. I researched "Game randomly freezing while playing" and I had several results that were surprisingly what I was experiencing on Age of Empires II DE.
While I decided to download Age of Empires II DE on my other computer just to check if this is a bug or something is wrong with my Desktops hardware, BIOS and Graphics driver versions. I decided to play Age of Empires II DE on my other PC which is a laptop and zero problems occurred. It was working perfectly even with the new DLC installed.
I am going to try these and sorry for wasting your time when I realized this isn’t a bug but more of a hardware and firmware issue that I have to fix on my end.

Updated the BIOS to the latest version which has resolved this issue. Didn’t have to do a hard reset.

@Felizon89 well this is strange, it was working yesterday but today it froze on me.

Should I just send out a file that has a list of my specs so you can share it to the rest of the team?

This is so weird

just found these 2

(3) [SOLVED] Age of Empires 2: Definitive Edition - stuttering/freezing every few seconds : aoe2 (

Are you using a third party antivirus?

Yes, i have Mcafee installed.

I have also been researching about this recently which seems to be what I have been experincing. It does mention to let the developer know about the issue.