Game keeps Crashing at Sundiata Campaign (1. Mission)

Game Version:

  • Build (101.101.33315.0 4426672
  • Platform : Steam


Game crashes at Sundiata Campaign when enemys destroys a certain prebuild house. See screenshot attached (1.).
Also campaign continues when Sundiata dies , even there is an achievement that he must not die!
See screenshot attached (2.).

Reproduction Steps:

  1. Play the campaign, and let enemy destroy house, marked in screenshot.
  2. Let Sundiata die.

Yeah had a crash in this same mission, not sure if that was the reason though.

Replayed it again, that circled house just disappears randomly at some point. I guess the game crashes if that house can’t be found? Not sure.

I am having the game crashes but with the Sundiata Mission 2.

For me it is not very clear what make the game to crash because I’ve tried to play different ways. Even I’ve tried to play in Standard difficulty with same crashes.

I used to save the game very often because I don’t want to start over. So I’ve checked that when I destroy manually a certain prebuild house, being attacked by the enemy, the game crashed. Otherwise, if I destroy the same house at the very beginning then nothing happens.

Now I am getting random crashes when I reach the Castle Age always.

Does somebody have the same issue with mission 2?

Game Version:
Difficulty: Moderate
Build: 101.101.34223.0 4509956
Platform : Steam
1 Like

Yes, mission 2 crashes on me, too.

The problem is the AI tries to attack the Granary buildings. Which is typically the instant right after destroying that building circled. If you make Mangonels in castle age and destroy the three Granary buildings (sadly they cannot be deleted) your game should not crash at all in Sundjata 1. Similarly there are these buildings in Sundjata 2. Destroy the ones in your base and the ones in your allies that are right next to you and that mission should also no longer crash.


seems it works. Thanks! but it should be fixed asap.

Thanks for the report and the additional details, everyone! We will get this issue passed along to the development team to investigate!

Playing Sundiata Campaign on Hard mode
Before in Mission one, I got constant crashes to desktop (no freeze before, just crash). Tried CC-Clean + PC restard and it did work again yesterday.
Now in mission two today, the same problem, no restart no clean nothing changes anything.
Nearly predictable every time the game was going to crash. If I used another savegame or I start a new game, always nearly at the same time, I got that crash.
I reduced graphics from Ultra to minimum, no changes!

I checked memory when crashes occur: only 5gb out of 16gb available were used. On each partition minimum 100gb drive space available, so should not be temp files growing too large.

Crashes occuring on current verison updated to least available December 18th 1am CET+1 and did already occur 2 days before.

I had that issue weeks ago (but then with game freeze so I needed to alt+F4) while playing Saladin campaign iirc… since then the problem seemed to be gone


seems to be fixed with the recent update, at least it has not crashed again since then

1 Like

no, it still keep crashing

Hello friends! Our QA team managed to reproduce and write up a bug for the issue, so thank you all for providing the information and details to help in the process. We will see about including it in the future build for those of you who have not already worked around the problem, and recommend checking out @ShulkerB’s notes if you want to see if they work for you right away:

Watch for the fix in a future build, and thank you again for the report!

1 Like

We just released an update that may resolve this. Check it out and let us know if there are still any issues. The full list of updates can be found here:

Age of Empires II: Definitive Edition — Update 34699

1 Like