Game not working since update, stuck in multiplayer loading screen

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 11179620
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

after updating my game to the newest patch and buying the new dlc, my game crashed multiple times and won’t load into multiplayer games now.
I’m stuck in the loading screen forever.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)
    tried 10 times

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
the game would work

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


I had the same issue. I solved it by disabling a control group positions mod which also made my UI disappear during single player game.


doesn’t work for me sadly


now i got timed out and cant try anymore… i’m not even angry anymore, just laughing


Try to disable other UI mods. They might break it as well… I had the same game behavior as well in unranked lobby games.


yeah i disabled literaly all my mods. still stuck in the loading screen


pay money so you can’t play the game. why wasn’t there some sort of PUP release for this? surely they can somehow release a beta and remove access for rome civ as well as AOE1 section.


I have the same problem, I disabled the tech tree ui mod and managed to start a single player game but the ui dissapeared. I tried a multiplayer game again and got stuck in the loading screen again.

1 Like

Hi There! same issue after release update In steam!.. 8/8 games with that issue…hopefull they fix asap.

Same issue here, can’t join any games today :frowning:
Lost 100 elo just with because of this nonsense!

I got the same problem since the update. tried reinstall but couldn’t fix it. played the game for years with no issues.

It might be possible that, as some users said, UI mods that need to be updated are interfering in th estability of the game. We’re also tracking many issues with lobby filtering and joining lobbies through URL. Sorry for the inconveniences.

Hi, I have been experiencing the same problem. After the return of Rome update came into effect (I bought the dlc) I tried to play an aoe2 multiplayer game, the first time I tried it worked (with all my mods active, playing as the Britons on multiplayer nomad) but one member of the enemy team disconnected immediately after starting the game. Before resigning one of the team members mentioned that it was the 8th time on the day a player disconnected immediately after loading the game.

After that game I haven’t been able to play any other ranked game. I already tried deactivating the mods, but it didn’t solve the problem, I am getting stuck on the loading page and just keep losing ELO with each try.
Each single time since then it has been my name the one that doesn’t get the checkmark next to it.

As a reference on all the next tries (the ones that failed) I got my preferred map (team islands which I like to play as the Italians)

Hope this might be useful for tracking down the cause of the problem.

Can you send to us the minidumps (.mdmp) that correspond to the day where this happened? Those could be found here:

“C:\Users\USER\Games\Age of Empires 2 DE\logs”

and have this format


same problem here, 10 / 10 times stuck on endless loading screen, getting timeout by the face and losing elo, hi anyone trying to fix this? (no mods enabled btw)

Yesterday I went back to the game and I had no problems, so I joined a few matches. However today on my 3rd match the problem came back and I cannot play multiplayer games again.

I looked for the .mdmp file you requested but the latest one AoE2DESteam-71094-2022.11.07-17.59.29.mdmp (460.4 KB) is from november-2022.
There is however a folder with .txt files that match the time of the last game (Game I could not play because I got stuck on the loading screen again). I am attaching the contents of that folder

2023.05.19-21.47.05.txt (24.2 KB)
Main.txt (2.1 KB)

I wonder what might be happening, because on all the 3 occasions I was playing ok, but on the 2 days that I got stuck on the loading screen, all the subsequent attempts also ended up getting stuck on the loading screen. In my experience closing and opening the game do not solve the problem, but restarting the PC seem to work.

Reading the log it looks like the game says that I have 2 mods active (useless plant remover and Default UI with Economic Upgrades Progress and Green), but when I go to the mods tab inside the game

none of the mods are active. (Yes, I did scrolled down and check all of them)

I recommend you to try some stuff:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.

b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.

c. Copy your user folder to a safe place, it has lots of numbers.

d. Delete the original folder

e. Verify your files in Steam, AoE2 game, Properties, Local Files.

f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

Don’t forget step c :slight_smile:

I “solved” my problem by disabling the ingame control group panel (not sure how this is called) AND all mods.
I will still send the minidumps in case it is useful in any way:
2023.05.17-16.21.59.txt (45.4 KB)
Main.txt (2.4 KB)