Game out of sync issue on Xbox

Yes- this issue is getting old fast. The latest update did not help at all. I’ve tried 8 different games on 3 different days, with all players and with ai, with all Xbox and cross platform - none of them work.

how come for xbox players they dont need to provide the replay from every desync’d player? but for PC we have to?

The issue might come from villagers auto assign.

@Felizon89 Could you clarify this? Should we try using or not using the auto assign? We were going to give it another try tonight to see if it worked or not.

@Lethalweapon450 I’d guess that it’s an issue when using auto assign. I always use auto assign for the convenience. And the issue happens almost every time

1 Like

@HerKing629 I use it most times as well bc of convenience but idk that my buddy does. He operates with a lower villager count. We’ll try to run one tonight without either of us using auto assign

For anyone following this thread and having Xbox de syncing errors, going without the villager auto assign actually worked. Kind of a pain in the ass but we were able to successfully finish two games back to back.

Just want to confirm I have also tested this through a number of games and auto-assign is the issue. It is usually ok for 1v1 matches but continually de-syncs in group games.

Playing arena is working with auto assign

I was told my topic was too similar to this one. So i’m copying my report here i guess. sorry if this isn’t propper etiquette

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 85614
  • **GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED


The game is desyncing. I was playing testing with myself on Xbox Series X. Both versions were up to date. I let myself on xbox try to bloom as much as it can while occasionally changing the villager priority automation. At around 1 Hour 23 Minutes into the game, it came up with a desync glitch error notification. The very last action I did was telling a group of 2-3 villagers to build a wooden wall (if that matters)

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

800% of games done on Xbox will desync at the 1 hour mark if not sooner.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play a game on or with an xbox player
  2. Play the game for over 30 min. The longer the time goes on the more likely it will occur. In the meantime, have the xbox player do things like make villagers, and use the Villager Priority automation system.
    (not sure if its required or not. I can do testing later…) Maybe even play on a water map and have fishing ships involved (not sure if its required or not. I can do testing later…)
  3. have the game desync, and instantly waste a boat load of time on a desyncing game that can’t be recovered…

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The game will Desynch. The game will end, and a useless restore file for a desynced game will be made. reloading the desynced game’s restore file will also result in the game instantly being desynced, or have the message “you have been defeated” instantly pop up for all parties.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

I will add that since being told it’s probably villager auto-assign, I’ve been using the advanced interface on Xbox, and setting my own ratio for villagers. It’s technically setting up villager automation, but isn’t causing desync for me.

Hello! I have facing the same problems as reported in the thread. With about 30 minutes of gameplay, the match ends, appoint this out of sync error, and it is not possible to conclude the match. I always play with my brother, each on their Xbox, and the problem started about 15 days ago. I’m going to try playing without auto assignment, but it’s not even close to ideal. I hope they fix this soon.

I’ve been playing around with this a ton. Mega random works fine every time. It’s the base maps for me. I select any base map and as soon as the main battle starts I get out of sync.

Still happening. I have got the out of synch error in the last 3 games I have played (ranked, 2v2, Xbox only, at least two of the games were on nomad) over the last couple of days.

I love this game but it’s really frustrating that this keeps happening, especially as it happens quite late into games.

1 Like

Same issue for me. Xbox only. My last 4 games ended with out of sync error.

Game is unplayable right now :frowning:

1 Like

We are seeing the same thing happen to us as well. last 6 games (ranked or unranked) the sync issue comes up around the 30-40 minute mark for us. This issues seem to come up for us after the June update for Xbox. This is making the game unplayable.

We are all on xbox only.

1 Like

AOE 2 HD is definitely unplayable. I experience the same issue when I cross play with my friend on Xbox. It has happened when I cloud stream the game and when I play on my PC. We’ve decided to switch to AOE IV, but that game has its limitations and doesn’t have the same nostalgia!

because we can’t open “my computer” on console. trust me if i could i would