Game Pass / Microsoft Store version - Not Launching

Hi there,

I Downloaded AoE III DE with the Xbox app using my game pass subscription. When I then launch the game it shows the small jpeg loading screen and it stays there indefinitely using no resources on cpu or disk usage.

Here’s what I already tried :

  • Launch the app in admin mode
  • Uninstall/reinstall
  • Move the game on another drive (SSD)
  • updated my GTX 1080 drivers
  • install the latest C++ visual studio drivers

If anyone could help me to launch this game I’ll be very grateful.

Thanks

4 Likes

Yeeah… so the Store evrsion is currently completly broken for almost everyone…
You need to wait for the next patch to fix everything ;D
Sorry :frowning: <3

1 Like

Hi @Lowanbel, Have you tried all of the suggestions in this support article?

If you need further help, please submit a request to the support team here:

https://support.ageofempires.com/hc/en-us/requests/new

1 Like

I am having the exact same issue and I came here hoping to find a fix but it seems like I’m out of luck.
I tried all the options in the link above and nothing worked so I logged a support request.

1 Like

Hi @RadiatingBlade,

Yes, just like @Kuberan92 here, I tried everything on this link but no change in sight. I guess I’ll wait for the next patch and see if it solves anything.

Thank you

2 Likes

Does anyone have any insight as to when the new patch is coming out? Is there any other way to play the game or download a previous version? Just bought the game…

Same issue here, tried everything possible to fix. Contacted supported and currently back and forth with them. The problem is it doesn’t even crash, there’s no error in the logs or DXDIAG either.

I used ProcessMonitor to see what the exe is doing and it seems its in a loop going through the same registry entries over and over again and explained that to the support person contacting me.

No reply since, but this has to be a widespread issue as there are a lot of reports on the store reviews with the exact same issue. Unfortunately as no error is being logged its hard to tell what the problem is, but due to the looped registry entries having to do with Xbox Sign in and “Tokens” I assume the app is having problems verifying / connecting to the Xbox app and just doesn’t launch. That’s my guess anyway.

2 Likes

During my exploration of a fix, this is the only error message I got.
error -2015294512

I got it when trying to use a different user account other than my admininstrator account hopefully they can find a fix soon. I just got the game also.

1 Like

Any updates yet devs??? I didn’t BUY this game to sit and look at the desktop icon and not being able to play the damn thing!!!

1 Like

Should have bought it on steam :stuck_out_tongue_winking_eye:

Unfortunately yes, but still, in 2021 this shouldn’t be happening.

Why? This can happen anytime everywhere lol

3 years ago, prototype2.
Not working anymore.
Thanks again :slight_smile:

Sure it needs to be fixed, but saying " this shouldnt happen in 2021 " is a not a valid reason.

It was a rhetorical statement. I do not care if it’s a valid reason or not. End of the day, I paid for a game that doesn’t work as intended.

How often do they put out patches for the game to fix issues??? Seems like this has been going on awhile now. Been having issues with AOE2 as well with it crashing mid game and AOE3 doesn’t even open

This is a known issue and we are tracking it to solve it ASAP. Thanks for the reports

2 Likes

Same issues here. Game stucks on splash screen

Yes they know, like he said.

I got mine to work, I changed to a newer xbox profile as I got another sub of game pass with a new account (AoE III : DE wasn’t working on the new account) I went back to my old xbox account and the game started working.