Game randomly crashing in multiplayer 30 minutes in, LAN via Hamachi broke on last update

Game Version:

  • Build: 101.101.39284.0 0
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: jdizzleone

Issue:

The game is randomly crashing during multiplayer custom games, anywhere between 15-50 minutes into the game. Happens in maybe ~60% of games. When it crashes, typically what happens is the game just instantly exits and I’m taken to my desktop. Laptop is Dell XPS 15 9570 (NVIDIA GeForce GTX 1650). I’m playing against a family member in the same house on the same Wifi connection, and both of us have firewalls turned off (both playing Microsoft/Xbox Live version). The crashing always happens on the Dell laptop, but never the other one (the other being a LG Gram 17). One time we both tried to play online with other people in a 4v4 match and the Dell got disconnected <10 minutes into the game.

We’d actually found a solution where it wouldn’t crash if we both used Hamachi (Hamachi lets you self-host a VPN and connect via LAN) and I could host a LAN game on the Dell that both of us could connect to (for whatever reason the LG couldn’t), but the recent July 21st AOE2 update broke this. Now the LG is no longer able to connect to the Dell’s LAN game on Hamachi, with the error: "Unable to detect Battleserver (Error: R_NATFailure). Without Hamachi, neither of us could ever connect to each other’s games on LAN even before the update.

This is pretty ridiculous and such a buzzkill having a game crash an hour in with no recovery options. After trying so many different things and finally finding a solution (Hamachi), the latest update broke this functionality, and so has practically made the game unplayable again. We’re on the same home Wifi network and just want to play LAN, I don’t understand why this has to be so complicated.

At least it looks like this issue is limited to something specific to the Dell XPS 15 9750. Have tried updating the OS and drivers to no avail. Please let me know if there’s anything else I can try to fix this ridiculous bug that practically ruins the game.

Possible approaches to fix:

  • Figure out what’s causing Dell XPS 15 to crash
  • Figure out why we’re not able to host LAN games

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Play 1v1 multiplayer game connected to another computer, both computers being in the same home connected to the same Wifi network
  2. The Dell XPS 15 9570 laptop randomly crashes to desktop 30-50 minutes into the game. Note: for the non-crashing player, the game doesn’t end as the AI seems to take over the crashed player at this point (not sure if this is unusual or as intended).