Game spontaneously crashes after latest update

Hi @DBodes
Can you tell me exactly when this happen? We’re tracking that joining a lobby using an URL the game may crash.
Can you also check if the game is generating mdump files?
Thanks for the report and sorry for the inconveniences.

The game crashes in ranked 1v1 and ranked team games. In a solo game to. Suddenly the game closes and it disappears.
Here are some details from the last game:

2023.05.17-18.43.38.txt (10.1 KB)
Age2CrashReport.txt (4.1 KB)
DxDiag.txt (113.0 KB)

1 Like

Just happened the same at me too, it was 3v3 ranked arabia.
At around the 12th minutes, it just dropped me out to the desktop.
Because of the hotkey issues in the recent Rome DLC (which I bought) I freshly reinstalled the game yesterday…
Earlier never had such issue.

@DBodes @moleMTL is your game generating mdumps?
You find those here:
“C:\Users\USER\Games\Age of Empires 2 DE\logs”
They look like:

Overlays from Nvidia, Discord and Steam can also cause crashes. You should also add the whole folder of the game to your antivirus exception list after every update. Sorry for the inconveniences.

FYI. Checking the error logs of @DBodes I noticed a lot of r-link errors which most times indicate an error with his cross-play configuration, e.g. using other Xbox account signed in (not connected to Steam account for Xbox/Store clients cross play) or lack of installing the latest MS Store (Xbox) updates although Steam client did update the AOE2DE game client.

Hello, On my side I checked for the minidump, but there is no such in the mentioned folder. In my case the crash was very quick, just dropped me out to the desktop, no slowing, no lagging (there was some game lag though earlier, but it looked like a normal network lag) prior to the crash. I reported that crash in a different ticket also
maybe it is a different kind of issue.

1 Like

Everyone i know on xbox with the return of rome dlc is also having a similar crashing issue.

Unfortunately there are no current mdump-files. There are only old ones from february.

In the last months every second patch create the problem and after the next patch the problem is no longer there. I hope you plan the next patch very soon :wink:

In my perception i do nothing special in the moment of the crash.

Are you getting the bugsplat window?

No, the game closes und the desktop is on the screen. No window to report the bug, no hint what closed the game.

Edit: I startet the game just a moment ago and there the bugsplat window appears after starting the game. I sended the report with the link of this thread. In the first time the problem occured, there was a ingame window after starting the game new.

May Hot Fix - Build #84485

I opted in to the beta in Steam, looks like the problem was solved, I could finally finish a single RoR campaign without any sudden closing to desktop. Will keep updated here.

1 Like

Ich bekomme beim Start über Zuschauer-Dashboard ( eines aufgezeichneten Spieles BUGSPLAT.
Gibt es dazu BITTE eine Lösung ?!

I had an error happen to me that wouldn’t allow me to load Age of Empires, and I wouldn’t even be able to reach the loading screen. Below is what I did to fix the issue.

Possible solution to game crashing before it reaches the loading screen and error message: presense data missing

Delete all of your mods you subscribed to in your folders. This worked for me, just letting others know.

1 Like

Nothing works. Crashes in the ranked lobby, crashes in the ranked games…
Severall De- and Installations. No Mod activated. Updated every possible driver.

No bugsplat window any more. I have no further ideas…

I’m a big fan since the days from the expansion The conquerers and buy’d every AoE2 Game Version and DLC. But now i’m very disappointed… Unplayable for month now

Did you try disabling overlays?

hey @Felizon89 the game doesnt seem to generate mdmp files anymore, only bugsplat. is this intended? cause iirc log/mdmp gets generated and then gets sent to you guys via bugsplat so if no files are generated, nothing gets sent.

after today’s update the game is not launching at all… I reinstalled everything, ran different fixes. Nothing helps. All other games are working perfectly fine

Hey, i disabled Steam-, Nvidia- and Discord-Overlay and now it seems to be stable. I can’t find a option to deactivate the xbox game bar.

But 2 Games in a row without crash.WOW! I hope that continues :slight_smile:

Mdumps are generated now in a temporary manner.

does this mean its only sent to you guys if we send it via bugsplat? cause I just had a crash today and while with the bugsplat window still available, I checked log folder and no mdmp files there at all.