Game stays in loading scene forever

Either im ranked match, lobby or specting i get to this scene but stays as in my computer still trying to connect forever, so cant play any multiplayer games.

Restarting the game worked for me

I’ve restarted the game, reinstalled it and restarted pc and still in the same situation

Have you run the multiplayer benchmark. If so, did your score pass the threshold for allowed multiplayer machines? Also what are your PC specs, and internet connection speed? Do you have any antivirus or firewall rules that could be blocking your game from being able to connect to multiplayer matches?

I have the firewall off, my internet speed is 50 mb, and my multiplayer bencharmark was ok for multiplayer. Ive been playing this game for months. Out of nowhere this happened. I have validated steam files of the game twice, and still nothing.

Tried to do the benchmark to show, and it stays like this forever as well.

Wow, ok it appears then that your computer/internet should run/handle the game fine.

In that case it appears that there is some sort of crash when attempting to start a session.

  • I would try this next:
    :hammer_and_wrench: Manually update Microsoft Visual C++ Redistributables and restart your machine. You can find these files HERE.
    If you are using a 64-bit Operating System , download the vc_redist.x64.exe file.
    If you are using a 32-bit Operating System, download the vc_redist.x86.exe file.

  • Also I would do this as well:
    Remove mods and add them again one at a time.
    Some mods may not run well with the game after a new update. Removing all of the mods and then adding them again one at a time will help to identify if any are causing an issue.

  • Also I would turn all your graphic settings to the lowest (even experiment with windowed mode etc.) to see if a graphical setting is hanging up things (what graphics card do you have?).

Ive tried taking all mods out, didnt work, ill try the c++ solution, just to ask, which redistributables am i going to redistribute? cause i have no idea what it means.
btw my graphic card, i know is not the best but it worked before…

A redistributable package (or a “redistributable”) is a library of components required to run certain Windows applications developed with Microsoft Visual C++.

In our case for your machine, Age of Empires 2 DE requires these vc_redist.x64.exe files to run the game.

All you need to do is download that exe and then right click the file and “Run As Administrator” and that will reinstall the files to your computer.
Restart your computer, and give it another try.

Tried it, didnt work. If you have a discord or somewhere else we can talk, or even if you would be amazing if you can help me via TeamViewer. Cause i play some tourneys this week, even if there is no money involved i dont want to lose cause AW. I dont know what else to do.

You could also try closing Dropbox before playing MP online. If it did work before there must be something else that changed in the meantime that’s blocking it. Close any other app (running in the background) you don’t need and that could interfere especially when playing tournaments.

ill try that, but i used to play with discord, dropbox and even some web pages (youtube = music) opened before. So i doubt that it will fix the problem but at this moment i’ll try anything. But thanks for taking the time to suggest a solution! I’ll write what happens in a bit.

Ok at this point, if you have reinstalled the redistributables, reinstalled the game, removed all mods, set all graphical settings on the lowest, stopped all anti-virus/firewall, and killed all non-essential programs running in the background … then the problem is not with you - it has to be some bug in the game and it needs to be reported here.

I’m afraid that the only other things that you could try while you wait for a response from the bug report is the following:

  • Run game as Administrator
  • Run the game in Windowed mode
  • Try different game resolutions (with without vsync)
  • Try a different computer?

I’m afraid, aside from the above, that I’m out of ideas :frowning:

1 Like

It finally worked, probably the 30 restarts did it! THANK YOU VERY MUCH1


Great! Glad it is working :slight_smile: