Game still crashes randomly

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: latest on Steam at the time of writing, but has been happening for the last few patch

:arrow_forward: ISSUE EXPERIENCED

Game crashes randomly after a while (can be 10 minutes or 1 hour) I tried disabling all overlays, all the mods and re-installing the game from scratch. It can happen in the main menu or in-game

:arrow_forward: FREQUENCY OF ISSUE

It happens every time if you leave the game running for long enough, but sometimes you can play a short game before it crashes

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Enter the game
  2. Stay in the menu, play a game, singleplayer, multiplayer, doesn’t matter
  3. The game eventually crashes, bugsplat window opens

:arrow_forward: GAME FILES (SAVE / RECORDING)

I wanted to add a crash log file but I opened the file myself to check it and it’s empty

Bump, still happening, I just want to play the game D:

Are you sure you disabled all overlays?Nvidia, Steam, Discord…

100% I disabled the steam overlay and completely terminated the processes of Nvidea and Discord using the task manager, just to be sure

I would love to give you more information about the crashes, but I don’t think savegames would be very useful, as the crashes happen in the main menu too sometimes, and as I said, the crash report ends up being empty, anything else I could give you to identify the issue?

Is the driver of your GPU up to date?

Yep, Nvidia 750ti update 474.44

I’ve had this issue also previously. No fixes or suggestions could help whatsoever. In the end, I just installed a Windows 10 partition just to play AOE2DE and now it works fine. Previously, this happened all the time on Windows 11. I note the OP is using Windows 7.

I might do that, I need to upgrade to play Doom Eternal and Spider-Man too, so it seems inevitable, I just hadn’t have the time to reinstall all my programs and stuff, but hopefully that fixes this game too when I eventually do it

really it shouldn’t come to this… Aoe2DE is a Microsoft product and Windows 11 is obviously a Microsoft OS. Why can’t it just work?

Seriously, if AOE2DE runs well enough on OSX (using gaming mode) then the joke is on Microsoft.

Windows 7? or a typo?
Windows 7 reached its end of life in 2020, meaning it no longer receives support from Microsoft. Consequently, it presents challenges for developers when debugging games on this outdated OS. Even if they manage to resolve the issue for Windows 7, it could potentially introduce problems for users on Windows 10 or 11. Therefore, it’s doubtful that the developers can provide an effective solution in this situation.

Your best course of action would be to upgrade to, or perform a fresh installation of, at least Windows 10.

I just hate basically everything about Windows 10, it looks worse to me, it’s full of bloatware that’s annoying to disable, it runs worse on my system, and I’m ultimately not used to it, I know windows 7 is not supported anymore, but like 98% of the software I want to use still works fine, and I don’t use it for much more than gaming, hence why I haven’t upgraded yet, but that 2% of software that I want to use means I’ll probably, reluctantly have to update to it soon

1 Like

Updated to Win 10 last week and that seems to have fixed it, no crashes in the few times I’ve played