Game Stopped working

Game Version:

  • Build 101.101.33315.0)
  • Platform (Steam)


So I’ve been playing aoe2 de these past couple of days, intensively, and it has been working perfectly. No bugs or crashes, nothing. But tonight I decided to try using the mods page and I downloaded the unique civ units and a voice pack with like 900 voice lines. As I was downloading the latter, the game crashed and I haven´t been able to play the game ever since. I’ve Uninstalled the game twice and reinstalled it, with no success. I’ve unsubbed those two mods directly from the age of empires website, and I did this before my second attempt at reinstalling the game. The game doesn’t even start now. only the start up logo appears on the desktop and then it disappears with no game launch and no error message. AoE2HD still works and I’ve checked other games as well and they work. I’ve also checked my hardware (which should handle the game with the uhd dlc comfortably) to see if anything died, but everything seems to be working fine. updated my gpu drivers. Can’t seem to get it to work… (My computer also doesn’t suffer from over heating issues)

I’ve also tried :
-Disabling and uninstalling my anti virus
-reinstalling c++ redistributable pack (I literally uninstalled all the older ones I had, and installed the most recent)

Here is a rough list of my hardware:

CPU: Ryzen 5 1600
RAM: 16G DDR4 3200MHz

Would appreciate any help I can get, I’ve completely fallen in love with this game again and it’s a shame I can’t play it, now that I want to so badly… Thank you.

Reproduction Steps:

  1. (Start the game on steam)
  2. AoE2 DE start up image appears on desktop
  3. Nothing.

Edit : when I try to launch the game from the executable in the AoE2DE folder, I get the error message “SteamAPI_RestartAppIfNecessary() has been triggered. Aborting startup.”

Hi, try typing SKIPINTRO in the Steam launch options.

I’ve just tried that and the -novid command, and it doesn’t work…

Ok, try this then.

The mods are not installed in the Steam folder, but in the Users folder in Windows 10. So I’m thinking even reinstall might not delete those files.

  1. Navigate into C:\Users\yourusername\Games\Age of Empires 2 DE\
  2. Find two folders with a lot of numbers.
  3. Click through both of them, and find the mods folder and then the subscribed folder.
  4. Delete all folders inside.
  5. Try to start the game.
1 Like

That was exactly it. I thought that as soon as I unsubbed directly from the aoe website, it wouldn’t be downloaded along with the rest of the game when I did reinstall it. I’ll provide a link to the mod that caused this…

Thank you so much!

Le mod :

1 Like